New drive not recognised by disk manager but seen in device manager OK


I am trying to add a new drive to a system but it is not seen by Windows disk manager. 

System is Windows XP Pro SP3 
Motherboard is ASUS PN5-E SLI. 
New drive is Western Digital Caviar Green 2TB (WD20EARX) SATA III. Purchased yesterday. 
Drive is recognised by BIOS. 
Drive appears in device manager under  disk drives and shows status as “This device is working properly”. 
Drive also appears in device manager under IDE ATA/ATAPI controllers. 
Read  Speed test initiated from device manager IDE ATA/ATAPI controllers passes. 
Western Digital Data LifeGuard diagnostics recognise the disks and shows SMART status as pass and Quick test passes. 

System already has two other HD. WD3200AAKS (320G system drive) and WD20EARS (2TB, SATA II) 
I added the 2TB WD20EARS drive in back in June without problem. 

I have tried with and without a jumper on pins 5/6 of the drive to force into SATA II mode. Without the jumper the Read Speed test initiated from device manager IDE ATA/ATAPI controllers shows “The current transfer mode is Serial ATA Generation 1 – 1.5G”, with the jumper it shows “The current transfer mode is Serial ATA Generation 2 – 3G”. The test run OK in both cases. 

I have tried using the SATA and power cable currently going to the other 2TB drive (WD20EARS) but it made no difference. So it is not a cable problem. 

I put the drive into another PC (Windows 7, Gigabyte P55A-UD3P) and it was recognised without problem. So the disk is OK. 

I have been looking at this for half a day but no joy. 

Any ideas? Something obvious hopefully… 

I’m having a similar issue with a new build.  The mobo is an Asus P6X58D-E.  I’m installing some new WD 1T disks as well as some WD disks from an existing system.  The boot/system drive in new, and works fine.  The bios sees all the disks, but Windows 7 does not see the two WD 1T disks, or the drive from the old system (which has my backup on it!!!).

I am not using these for RAID, so none of those settings have been changed in the bios.

OK, I think (99% sure) I have this sorted.

There seems to be an issue with the nVidia SATA controller driver and this new SATA III drive. I guess they are “incompatable”. This driver is found in the Device Manager under the section “IDE ATA/ATAPI controllers”.

The solution I have in place now is I updated the driver (actually a version downgrade) from nVidia nForce Serial ATA controller (version dated 9 Apr 2010 to the generic(?) Windows XP Standard Dual Channel PCI IDE Controller (version 5.1.2600.2180 dated 1 Jul 2001). Once in place the new drive appeared in the Disk Manager.

I also tried using the driver version found in the chipset package for the motherboard (found at and called NVIDIA nForce 430/410 Serial ATA Controller, version 5.10.2600.666 dated 24 Apr 2006) but it seemed to slow the boot time dramatically to ~5 minutes. The generic Windows XP driver I am using now does not show this behaviour.

I’m not exactly sure what I am missing out by using the generic Windows driver rather than the “proper” nVidia driver but the new disk is now recognised which is the main thing. I guess w/o the nVidia driver there is no RAID support(?)

It also feels odd to be using an IDE driver for a SATA drive but perhaps that speaks more to my ignorance than anything else…