New drive not rebuilding only sits there showing 3 drives

OK, I ordered the following:

Western Digital Drive kit for WD Sentinel 2 Cache 3.5-Inch Internal Bare or OEM Drives (WDBNSH0020HNC-NASN)

This is the exact match needed for my DX4000. Running latest firmware, have all updates and update rollup installed.

I slide this new drive in as shown, and after several hours my display shows nothing new (not showing “Rebuilding” like it should) Dashboard shows RAID 1. Drive 1 as Normal, Drive 2 as Normal and Drive 3 as New Drive.

I have another exact same unit and added a drive to it last week. Within 5 minutes of inserting a new drive in that unit, the display shows rebuilding. But on this problem unit it never does.

Any ideas?

Called support and they are as dumb as a fence post. Took three tries explaining this. After second time, they repeat my problem, “so you are trying to backup your Sentinel?” Hello! Then they tell me I need to download the Server Recovery ISO.

Recover what? The server boots and works just will not utilize the new drive and convert RAID from RAID 1 to RAID 5.

Do you see any alert messages on the LCD? You can check page 11 for a description. Are you also using RAID 1 for the other unit?

No messages on LCD. After inserting new drive, nothing  changes on the display. If I press the up or down arrow on the display the only change is it goes from 2 drives to 0 drives. After about an hour it goes to 3 drives. But the dashboard still shows RAID 1 and the third drive just shows NEW DRIVE.

On the other unit it was RAID 1 until I inserted the third drive and then withing 5 min. it said on the dislplay Rebuilding or Migraiting. Can’t rembmer which. And on the Dashboard is showd it was comverted to RAID 5 and migraiting or rebuilding the new RAID.

So you originally ordered it as a 4TB system? In other words, are the EXISTING drives all 2TB?

Were both drives ordered from the same place?  From WD?  can you tell if they have the same firmware?

Exact same model number ordered from different vendors. Came in same packaging, both with same small instruction sheet to make sure you insert it properly in the DX4000.

As for firmware I don’t know but could be. If different firmware is issue, why does WD sell them if they only work with other drives or DX4000’s if firmware not same?

Correct. Ordered as 4TB and configured as RAID 1 so about 2TB available less operating system and other software WD installs. And both drives that came with unit are both 2TB drives.

Here is pic of new drive.


Well your pic is not showing up yet.  There is a thread in here somewhere where someone bought what looked like the correct black drive from newegg but had a diff firmware and would not work.  But if it was sold as the propper kit it should work (I would think)

Does this help any?

<?xml version="1.0" encoding="UTF-8"?> - WDC WD2002FYPS-02W3B0 WDC WD2002FYPS-02W3B1 WDC WD2009FYPX-09AAMB0 WDC WD3009FYPX-09AAMB0 Hitachi HDS5C4040ALE630

Pooh looks good till i post then the format scrumps up

The one I have is WD2002FYPS-02W3B1 which is listed on the WD site for the DX4000… Maybe the 02W3B1 is the firmware part? I say this because you can use either 02W3B0 or 02W3B1.

My new drive is 02W3B1 and older drives I think are 02W3B0. But if I can’t use the 03W

B2 then they should say that on their site.

numbers look good from your post pic still not showingtry the diags on it ?

WHen I plug the drive into the DX4000 after an hour or so, it shows as a new drive but doesn’t build or become part of the RAID. Remains Raid 1 using 2 drives and 3rd drive just sits there.

So last week when this happened, I RDP to my DX4000 and installed the Datalife diag tool your recommending. It shows one drive so I assume the tool sees the new drive and doesn’t recognize the aray. It tested the drive and it was fine and passed the tests.

You never installed any of the Intel RST stuff did you? (do not)

Normally if it is an unexcepted drive it will tell you.

I assume you have rebooted.

Try the drive in the other slot?

Never installed any software and did try 4th slot. See current screenshot below with it n the 3rd drive. It should show Rebuilding or something like it is taking action on the third drive. All it does is sit there for days and does nothing. Like I said I have two DX4000’s and it went fine on the first one.


Looked at Event Viewer and found these entres:

1st entry: IAStorUtil.StorageAction.DiskReset action failed:  FailedToEraseConfiguration

2nd entry:  Disk 12 failed reset

3rd entry: IAStorUtil.StorageAction.VolumeModify action failed:  FailedToClaimDisk

4th entry: Volume 3 migrate R1 to R5 failed to start

Then shortly after this is when the drive finally shows up as a new drive inserted and nothing else ever happens. The drive just sits there as a “New Drive has been inserted”

That first faield to erase entry has me wondering.

Could you attach the disc to an xp or win7 box and do a dispart clean on it?  Making sure that youy list disk and clean the correct disk.

Then put it back in the WD and see what happens

OK, I tried it on an XP Pro, machine and then on a Win 7 64 bit machine. Neither would boot the OS. On both machines with this drive attaced to my SATA 2 port (Boot/OS drive was on SATA 1) it would sit at the Windows splash screen for more then 15 min. and I finally just turned the computers off.

OK on this computer my third one I have tried it booted.

Set the drive to active and did a Clean All.

Error saying "DiskPart has encountered an error: The request could not be performed because of an I/O device error. See the System Event Log for more information.

That drive now no longer appears in my list of drives in the diskpart screen when doing List Disk.

System Event Log:  Could not find any entries related to this in the event viewer

on my phone

reply tomorrow

You have lost me when you say you put the drive in a box and it hangs at the windows logo.  It should not be booting from this disc.  Simply add it to a working box so we can get too it.  Either as a slave drive or using a dock

When the system is up, open a cmd prompt

type diskpart > enter

list disk> enter

make sure you see/select the correct disc.  DOn’t want to wipe out your good OS

select disk (Correct disk)> enter

clean > enter

exit >enter

Then put the disk back in the WD box