New Device stuck on logo screen after updating manually!

#1

I just bought this device and want to update it but i couldn’t do it automatically update so I did it manually but after that it got stuck in the logo screen and no flashing at all even if I turn it off and turn it on again , no flashing and this is new wd live hub !! I will lose my mind becz of that 300$ for not working device for no reason !!

please help me

#2

please help me

#3

Hello,

Have you tried resetting the unit using the physical button on the back of the unit?

#4

yes i tried that and I kept holding it for 10 seconds

i think my only problem is the firmware didn’t installed completely so i think is there a way to reinstall it again , i tried everything but it didn’t work even i checked if the device connected via internet so i can do something from my laptop but unfortunately the device stuck in the blue logo screen and i can’t find access to reinstall the firmware again

#5

Hi - saw your post from Aug '16 - hopefully u fixed things - if not see my post from March '18. I managed to rollback to the very first firmware ‘upgrade’ and box is now working again. I have not attempted to do incremental upgrades - just happy to get the box working. No concrete evidence but contrary to what WD support advised (no need to do incremental upgrades simply install the latest) I have a feeling that incremental is the way to go but wil read the release notes first to see if I get any benefit from each upgrade.