New Beta Release - WDTV Live Plus Firmware Version 1.06.38_B (11/13/12)

WD would like to extend the opportunity to join a two week public beta test of the latest WD TV Live Plus firmware.  It will be available for the first 3,000 downloads.  Please post your experiences here in this thread.

To roll back, please refer to Knowledge Base Article 5800.

Note:  Thank you for your contributions.  This beta is now closed.  We are investigating the issues you reported from the beta, and are looking to have a final firmware release sometime soon.

1 Like

So far so good. Didn’t brick the device during the firmware update procedure. Everything seems a great deal less-laggy now, interface-wise. You folks wouldn’t mind posting some sort of list of what has been updated, would you? You know, like most normal programmers would? Or are we just expected to poke around blindly in the dark? :robotfrustrated:

1 Like

Thats why they released the beta, so you could tell them what they fixed and what they messed up. (wink)

1 Like

After powering up the Live Plus, Windows shares are not listed in the Network Shares list.

If I go into Settings->Network Settings->Network Setup->then choose Automatic, the Windows shares will then show up in the Network Shares list.

Note that when I go into Network Setup, the IP Address, Sub Net Mask, Gateway, and DNS are shown correctly, but I have to choose Automatic to get the Windows shares to show up in the Network Shares list. After I select Automatic, the IP Address, Sub Net Mask, Gateway, and DNS stay the same as they were before I select Automatic, however that makes the Windows Shares available in the Network Shares list.

1 Like

Scandy, this occurs sometimes with my current firmware installed for my Live Plus (v1.05.04_B) and I need to do what you describe.  This could be a lingering problem with the firmware, or I have a sneaky suspicion this is a WIndows 7 network “glich”.

the subtitle key doesn/t work. had to go to options to turn them on/off.

1 Like


1 Like

installed the beta two days ago, almost everything is fine. Looks better, the interface is smoother and more responsive. No networking issues or playback of most files that I tried so far. The only place might be inside Netflix, I perceive a bit of choppyness during playback. I’ll have to test with more movies to be certain. For example, I was watching Jumanji today where I noticed that effect. I have a 70Mbit fibre internet service, so it should be coming in at high quality when available. I will confirm in a few days.

I would like to congratulate WD to have used the beta channel this time around. 

1 Like

The Beta Firmware is MUCH better than the previous aborted firmware.  The starting play delay is almost back to the 1.06.16_B firmware times.  FF and RW are usable again (no huge delay to resume).

One odd problem is that 1.06.38_B seems to miss my Win7 machine sometimes.  Also it doesn’t appear to rescan the network as often either.  With the 1.06.16_B firmware I could go back to the main menu, select video/network again, and after a few times the missing machines would appear.  This firmware seems to scan once and not try again (or it’s on a much longer retry delay).  My XP machine has always appeared, but the Win7 one sometimes gets missed.  If I power the unit off and on again, the second round will have both machines.  Perhaps the timeout is a little low looking for machines?

I haven’t used the new firmware enough to know if the video redering process is more stable or not.  1.06.16_B’s used to crash occasionally if you were too quick on the remote (changing between FF/RW/play).  The menus would work, but you just couldn’t play anything until you rebooted (just would get a black screen).  So far it hasn’t happened with the new firmware, but I’ve trained myself to slow down with the remote.

Appreciate WD improving the MP4 playback.  Some recent files were displaying a “not supported” message with 1.06.16_B and now they work fine.

1 Like

This firmware version is performing much, much better than 1.06.34, but I haven’t noticed it performing much differently than version 1.06.16.

I have some .mkv files on my network share that I can play on other networked devices (laptop, PC, phone) but which don’t play on the Live Plus with the new firmware, although they didn’t play under 1.06.16 or 1.06.34, either.

My network share would show up fine under 1.06.16, but almost never shows up with 1.06.38, same as I’d experienced with 1.06.34.

The one thing from 1.06.34 I’d really hoped would carry over into 1.06.38 was support for the WD Live app on Android, but if it’s supported, I can’t find any way to pair up or otherwise get it to work.

My favorite thing about the newer versions is not having a “Are you sure you want to exit Netflix?” message pop up whenever I’m in Netflix and want to power down or return home.

All in all, the WD TV Live Plus is still my preferred networked media streaming device, and hopefully newer firmware versions will continue to make it even better.

Edited 11/21/12 1:00pm to add: YouTube Leanback is cut off a little on the right and left sides of the TV, so sometimes text isn’t completely visible.

I downloaded and installed this beta firmware yesterday and have seen some improvement in playing certain video format combinations.

Combinations I have :

  •   MKV(x264 video , vorbis audio) : this has good audio now but the video now ‘jitters’ every 10th frame.
  •   MKV(x264 video , AAC audio) : video and audio seem to play about the same or maybe a little better that previous firmware versions.
  •   MKV(x264 video, FLAC audio): play back  is about the same as before maybe a little better than previous firmware versions.
  •   avi(Divix/Xvid) : no real change here
  •   Mp3/flac/aac/ogg: play fine although randomization system could be a bit more random when files are stored in multi level folders.

above mentioned MKV files have embedded Advanced Sub Station subs and although the sub scripts are not completely supported the text is being decoded and displayed although the border on the text is now thicker than before for the ‘thin border’ setting and no longer smooth around the letters.

Personal DVD ISO : menus seem to be functioning normally and movie play back is good.

Playing video files from network share is good.

Navigation of the menus is more responsive compared to earlier releases.

Would test internet media streaming if there was support for Crunchy Roll basic account. Crunchy Roll says WD TV Live Plus devices support play back but this seems to be missing from the WD TV Live Plus like I have.

1 Like

Wolfpup - when you say “avi(Divix/Xvid) : no real change here” is that good or bad?  i.e. were they playing good or bad for you with previous firmware versions?

1 Like

fhall1 wrote:

Wolfpup - when you say “avi(Divix/Xvid) : no real change here” is that good or bad?  i.e. were they playing good or bad for you with previous firmware versions?

This is the easiest for any system to decode as the is such an old format that it is considered Standard Definition since even DVD players can decode this format. As such SD avi files get upscaled majorly on any HD device. So taking all those factors in to account they have always played ‘as good as to be expected’ since these files are not really meant to be played on a device like this unless your connected to an older SD TV which I had originally when I first bought my unit. I now have a 40" Flat Panel HDTV.

1 Like

I have 2 WDTV Live players. I use them with Windows 7 shares which contains music and video.

With the new beta software, one player consistently finds the Win7 share and the other occasionally requires an additional reboot before it sees the WIN7 share folders.

1 Like

I’ve had some networking issues.  I lose my network shares. It often seems to happen after we’ve used Netflix for a while without restarting the box. After restarting, it seems to take longer to discover the shares. I have made no network changes to any device. I’ve tried reapplying the network settings on the box, the only thing that works is a restart.

The box is usually always on, I only restart or unplug the unit if it freezes or if it doesn’t behave normally. It is THE multimedia device in our household. It connects to my NAS, a win 2008 server with RAID 1-0.

1 Like

I should add; I like the new Youtube interface. It’s better but is missing some good features like remembering the search results. The keyboard is nice with the suggested letters. It makes it much faster to add text when you don’t have a keyboard.

As for the Netflix interface, much nicer. As mentionned earlier, I also like the fact that there is no Yes or No prompt.

You know, WD support could have an online questionnaire that we could fill out with all the changes to see what changed so we could be aware and verify it. Cause, I’m sure there are many changes I haven’t or will ever notice.

I just installed this firmware, so far it seems faster (it responds to the remote alot quicker).

I have found that the audio on MP4 videos does not play, other videos seem ok.

I’ll keep testing, see if I have any other problems.


After having to rollback the 10/31/12 firmware update, I loaded up this beta version 1.06.38 B and it’s working well.  Thanks.

This is an update to my experience since my previous post.  I’ve had to roll back to 1.06.16, I’ve just had too much trouble trying to get my network shares to show up.  I’ve tried powering off and on, resetting the device completely, just resetting network settings, and rebooting my router, and I can only get network shares to show up about every ten or twenty reboots of the device  It’s not that big of a loss, since the only thing I was really hoping for in the new firmware was support for the WD Remote app on Android, which it doesn’t seem to have.

Say, support usb wi-fi chipset Ralink 5370 come from?