New 8TB My Book Not Detected by WD Drive Utilities

This is my first interaction here, so please excuse any inadvertent breaches of forum protocol.

I purchased and installed a new 8TB My Book external drive on my Windows 10 PC. The drive works fine and is quite fast! However, WD Drive Utilities is not able to detect the new drive, even though it can detect my other WD drives (e.g., 6TB My Book, 3TB & 2TB My Passport Ultras, etc. And, yes, I did download and install the latest version of the WD Drive Utilities from the website. I’d really like to be able to set the sleep timer for the new 8TB drive. Can anyone offer information or suggestions? Thanks. -Spin_Guy.

Is the 8TB unit a WD My Book Duo or WD My Book Pro? If so, and if you have already updated the app then perhaps it would be best to contact WD Support about this. You can do so over the phone or via E-mail:

On the other hand, if your unit is a WD My Book Live Duo then WD Drive Utilities does not support NAS drives at the time of this post. If are using a USB hub it may also interfere with the app even if it appears to work with other units.

Thanks for your response, Trancer. It is simply a “My Book 8TB”, not a Duo and not a Pro. I believe this is a very recent product release, and therefore not yet supported by the WD Drive Utilities. The factory default sleep timer is too short for my purposes, and the drive keeps going to sleep on me. This is a problem because it takes the drive a good 30-60 seconds to come out of the sleep state - really slows down the work flow. Per your suggestion, I will indeed contact WD support. Regards and, again, thanks. -Spin_Guy.

I called WD tech support. At first, the technician insisted that I was not giving him a valid WD serial number. After some insistence on my part, he did more checking and finally agreed that it was the valid SN for a WD My Book 8TB drive. I guess they’re still not fully set up for supporting the new product yet. Regarding my issue, he confirmed that the WD Drive Utilities do not currently support the new 8TB model, but that chances are it would be supported in the future. He recommended that I check the support site regularly for an updated release of the utilities. I asked if there was another way to set the 8TB hard drive’s sleep timer, and he said that there wasn’t. So, I’m stuck until WD decides to provide a software update. Regards. -Spin_Guy

Spin, I just got my 8TB My Book and I have the same issue here. The WD Security is not recognizing it. I guess we’ll have to wait for the update. I am upset that they did not test these before release the new drives.


Yeah, got the exact same problem with the WD Smartware and WD Security not recognising the 8Tb MyBook - It comes up with the message “Attach a WD Support device” …I mean wtf!

WD Utilities does see the drive and offer a few operations such as the sleep timer and format drive etc…

Very poor software/product that must have been rushed to market to try and compete with Seagate’s recent 8Tb release - this opinion is coming from a die hard WD customer who has only ever bought 1 Seagate drive in my 20 years of computing.

So yeah very very dissapointed in that the encryption is not working on the drive.
Emailed WD Support and they just ask me to install LATEST Drivers and SOFTWARE from their own website, I mentioned i am a software engineer and very knowledgable in this field but they keep asking to see LOG files for the drive in question.

Frustrated isnt the word.


Can u get the drive to lock?


No luck in locking the drive mate?

Sorry, I haven’t tried to lock the drive. In fact, I’m not even sure what it means to get the drive to lock. The only thing I adjusted was the sleep timer. Regards.

You can password protect the drive using the WD Security application but mines says ‘Attach a supported WD drive’ when it loads. If you have a minute can u try loading that app, it is located on the new drive.

Sorry, as much as I’d like to help, I don’t wish to install or test the password protect software on my laptop. I can’t afford for something new to go wrong. Again, my apologies, and best wishes for resolving your issue. -Spin Guy


They updated the software. Now it recognize my My Book 8TB drive. However, once you unlock it, there is no option for you to lock it again. The only options are deleting password or changing password. So I have to unplug the drive and connect it back. Then it shows as password protected.

I think this is a very basic option and I hope they can update the software to add this option.