New 4TB My Cloud Worked Great, Now it Doesn't

Hello,

I’m a newbie, this is my first post. I’m pretty computer literate, but, some stuff in this forum is over my head… Hope you all can bear with me and help me out!

I got a new 4TB My Cloud last week, set it up with no problems, and began using it right away. I have a MacBook Pro on a Verizon FiOS network (my Verizon router is probably too slow to really take advantage of the My Cloud’s speed, so I’m planning on upgrading it to a gigabit router soon…)

Here’s what was going on when everything was working well on day 1:

  • I could see the My Cloud’s “Public” folder right on my desk top and easily drop files onto it. Sure, the transfers were a bit slow, but I attribute that to my Verizon router.
  • I could hit the “Source” button on my Samsung Smart TV and see the My Cloud, and access everything on it. I could click right into “Shared Videos” and and play all of them right on the TV.
  • The Time Machine Backup ran and worked just fine.
  • I installed the WD My Cloud and WD Photos apps onto my Android phone and they worked just fine. Any photos I took with my phone were automatically backing up to the My Cloud. It was great.

I was exstatic. So, I took my iCloud to my office to connect it to my iMac that has an ethernet port to do my “big” file transfer. My dream was to have ALL of my movies and ALL of my music (my iTunes Library) on it.

With the ethernet connection at work, the transfer went quickly, overnight. I put approximately 800 GB of music (organized by artist folder) directly into the “Shared Music” folder. And I put about 180 GB of movies into the “Shared Videos” folder.

I brought my My Cloud home, plugged it back into my home network exactly the way it was before, and, all of a sudden, nothing worked the way it had before.

Here’s where I’m at now:

  • The connection is PAINFULLY slow. So much slower than before. When I mount the “Public” drive on my desktop, it takes for ever to connect. And as I dive down into sub-folders, each one takes FOREVER to open, if it even opens at all.
  • I pointed my iTunes library to the “Shared Music” folder, and it appeared to work… It “Updated the iTunes Library” and everything. But still, all of my songs have the little grey error icons next to them. iTunes says the file cannot be found and asks me to locate the file. Just clicking through the folders on the My Cloud is AGONIZING; so slow. Once I find one file, it’ll play like it should, and iTunes asks if it should use the location of that file to locate other missing files… But that doesn’t work. Something’s wrong.
  • This is my biggest, angriest issue: It no longer appears to work with my Samsung TV. When I go to “Sources” on the TV, I can still see the My Cloud, but when I click on it, all that shows up is one folder called “Music”… With only a fraction of my music actually visible. I can no longer see the “Shared Videos” folder. What the HECK? It was working fine a few days ago! When I tell the Samsung TV to show me video files that are on the device, it just says “No Video Files Found.” UGH!
  • My My Cloud dashboard is now incredibly slow to load/access. 
  • The “Content Scan” has been running for 2 days, now, with no end it sight. See screen shot attached. It is actually moving… Just very slowly. The “Music Tracks” scan started off fast… Went from 0 to about 113000 in about an hour, but for 2 days it’s been stuck at this 83%. Like I said the number of tracks IS slowly going up, just about a dozen or so tracks per hour. At this rate, the content scan will likely NEVER end.
  • The device is constantly clicking and whirring, now. I assume this is the endless content scan happeneing?

What gives? Did I screw something up my taking it to my office network? Did a new firmware update (I let it update the other day when I brought it home from work after the transfer) ruin everything?

All I really want is to access my videos on my TV again. And getting my iTunes Library working would be nice. Please, please, please, help me! 

Thanks. Sorry for the novel of a post!

 

The “Content Scan” is still running and with “Media Serving” ON within the shares it takes a long time to get things sorted. Especially is a lot of movies/videoes have been uploaded at once. I would say be patient and it will all come back. This happened to me and finally the My Cloud returned to normal operation.

1 Like

Thanks for the advice. This might be a stupid question… Do I need to leave the Dashboard open in my browser for the content scan to run? I have to this point. Had it sitting in the background on my laptop for 2 days now. If I close out of it… Or even take my laptop out ofthe house with me, will the My Cloud keep on doing it’s content scan?

Yes, the My Cloud will continue scanning as long as it has power. This is accomplished automatically, so the Dashboard does not have to be open nor does your computer have to be “on” … just make sure the My Cloud is NOT turned off.

It will all work out  :wink:

1 Like

Great news! As of about 2 hours ago, the scan appears to have completed… And my videos are all visible on my TV! WHOOO! Patience was a virtue!

One last question… The dashboard main page, as you can see, still says “Scanning” even though the scan was completed 2 hours ago. And I can still hear the device clicking and whirring and working. Should I just keep on waiting? Should it eventually end on it’s own?

Thanks!

In other words… the scans have all completed, but now when I go to settings --> media it says “Updating Database…”

I assume THAT is what’s making the drive still click and whirr like crazy… and what’s making it slow? Do I need to just be patient again, and wait for the database to update? How long does that take? There’s no progress bar or percentage…

Also… one more thing… Whenever I add new music or movies from now on, it’s not gonna re-scan the whole dang drive, is it? Will they show up automatically?

Thanks! Hopefully these are easy questions for you guys!