New 4TB mobile USB-C: 3.79GB available on Win7

New G-TECH 4TB mobile USB-C drive shows 3.79GB on Win 7

It showed up when I first attached it. I renamed it and created a folder on it. Then I tried to copy to it and got the message that not enough space was available. (Only 3.76GB available. Note that is GB, not TB.) Googled a bit, and installed Paragon successfully. Rebooted. Still only showing 3.79GB total capacity, 3.76GB available.

Below is a screenshot of the properties and what’s in the directory:

Any suggestions on how to access the full capacity of this drive without reformatting for NTFS? Thanks!

1 Like

I’m having the exact same problem on my 2TB mobile SSD on Windows 10. I connected the drive and properties showed 3.8GB, so I ran the reformat wizard that came on the drive to convert to NTFS and it ran smoothly. Restarted my computer, and the drive still only shows capacity of 3.8GB. I tried to transfer 5GB of data and Windows would not allow me to do it.

Firstly, you’ll need to make sure the drive partition/format is GPT (GUID Partition Table) and not MBR (Master Boot Record) which only supports up to 2TB

Secondly, for whatever reason you need FAT32 as the file system, you’ll need 3rd Party software to achieve this as Windows only support formatting FAT32 onto a max size partition of 32GB

In all cases, you need to format the drive again … so backup whatever data you have on it.

SOLVED my problem. Assuming you already tried to update the driver and that didn’t work, and reformatted to NTFS and that didn’t work, here is the solution that ultimately worked for me (I did not need to save any data on the drive, so this will properly reformat).

Instead of device manager, locate and open the tool called “Disk Management”. Just search your system for it or type “diskmgmt.msc” in the run bar (hold down windows key and tap R to access run bar).

In the bottom half of the screen you will see your various drives connected to the system. Determine which one is the problem drive (make sure its not your primary hard drive). On the right it will show the different partitions. One will likely be roughly 3.8GB… right-click that one and “delete volume”. Delete any other unnecessary volumes as well (you will need to keep the small “system partition”).

Then right-click on the remaining un-allocated space and select “New Simple Volume”. Follow the instructions to complete.

Note that I un-checked the “quick format” box to give it a full-quality format, and it did take quite a long time to do my 2TB drive. Maybe an hour or more.

According to information provided by WD about the Paragon driver:

With HFS+ for Windows by Paragon, you get read and write access for your new HFS+ formatted G-Technology drive in compatible Windows and macOS based computers without having to reformat the drive.

Formatting for NTFS works if you want to use the drive only with Windows, but I’m trying to set things up so I can use the drive with either Windows or Mac OS.

Do the suggestions above apply in that case?

@mikeh100 follow the link below for the steps to reformat the drive in exFAT which makes the drive to work on both macOS and Windows.