New 3TB Blue, partially dead on arrival?

I’m completely unable to figure this out, and googling hasn’t gotten me any closer to an answer. Hoping someone here will have an idea of what’s going on.

A few days ago, I bought two 3TB Blue 3.5" drives, a single 1TB Blue 3.5" drive, and two Inateck FE3001 external USB 3 enclosures. The 1TB Drive was installed in an enclosure (which has a dedicated power supply, not bus powered) and used Carbon Copy Cloner to create a backup clone of my boot drive. I’m on a late 2012 iMac, 21.5", if that’s relevant. No problems. I then removed that drive from the enclosure and stored it. I put both of my 3TB drives in the enclosures, and initialized both using the quick-initialization (not writing zeroes onto the entire drive). One is intended for file storage, and one for Time Machine backups. Here’s where things get screwy:

I copied about 350 gigabytes to the Files drive, and all went well. Then, it ejected itself and I was given a warning notice, “The disc was not ejected properly”. The Backup drive had no issue, and remained mounted. The File drive would mount after disconnecting and reconnecting the USB cable, but would at random continue to eject itself and I’d get the warning notice.

At this point, I started switching components to eliminate possible failure points: the wall outlet, the power cables, the USB cables, etc. In every case, the Files drive would inevitably eject itself, and I was able to eliminate the wall outlets, power adapters, USB cables, and enclosures. So, the failure is definitely following the disc drive itself; my first question is, what would cause this behavior?

I contacted the seller (bought on Amazon through a reputable 3rd party seller) and described the issue; I received authorization to return the drive for a refund/replacement. Prior to this, I tried one last thing: I initialized the drive and set it to Zero the drive in three passes (mainly because some of the data I had already copied to the drive included private info- passwords and the like.) Since that procedure completed, I have yet to see the drive eject itself. Could this have solved the issue? My gut says no, but I have no facts to base that on. If there’s no reason to return this drive to the seller, I’d rather not be a bother to them and simply keep the drive. One way or another, I need this drive, so if I do return it, I’ll buy another. Please enlighten me!

Is this definitely a bad drive, or questionable enough to justify returning it?

Thanks in advance!


I recommend you run a diagnostic using WD DLG. This will help you determine if there is anything wrong with the drive.

Data Lifeguard Diagnostic for Windows