New 12TB Elements Drive not working after power failure

My two-month old 12TB Elements drive was accidentally unplugged and since then it will not spin or mount. When I plug it in, it sounds almost like it’s trying to start spinning. There are a couple clicks, and then a few seconds of a hum, and it does that several times before stopping. I’ve tried it on a different computer, plugged in to different power sources, and even used a friend’s power cord (same model). Nothing is working.

I tried twice to connect to live chat support, but both times when I got to number one in line, my request was cancelled because there were “no available agents.”

Any help? Is there any resetting process that might help? I’m so frustrated because I just got all my old stuff migrated and the whole drive backed up to the cloud (it took DAYS), and now the drive is not working.

I have been using it exclusively with Big Sur and it’s been partitioned as a Time Machine backup and as a general backup. The drive was not writing when there was a power loss. (Or should not have been. It was plugged into a computer that does not backup to it and no information was being accessed at the time.)

Hello,

Please refer to the following KBA article: Testing a drive for problems using Data Lifeguard Diagnostics for Windows