Networking problems

Hi everyone!

I am experiencing serious problems with my WD Live Duo.

What happens is extremely strange and unfamiliar to me.

I hope the Community can help me to solve the problem.

Basically what happens is:

  1. If I try to access any folder typing \WDIP\Foldername I am able to enter the folder

  2. If I try to access any folder typung \WDDeviceName\Foldername I am not able to enter

Please consider that I checked the following:

  1. device firmware is uptodate

  2. I have full access to the shared folder

  3. the shared folder is totally empty (I also tried adding a few files)

  4. I have no DHCP problems

  5. All other devices on the network work properly.

  6. I also have an old MyBookLive, which I am able to reach/browse/modify properly

What can I do?

Many thanks for your help

Francesco

Make sure that you are using the correct device name.

Are you able to access the dashboard of the unit using the device name?

Thanks for your reply.

I am using the correct device name, indeed.

What do you mean by accessing the dashboard using the device name?

If I type \IPaddress on google chrome I am able to access the control panel of my WD.

In case I type \DeviceName, I get an error page.

Is that what you mean?

Thanks for any suggestion!

It sounds like there’s something wrong with your PC’s name resolution.

When you type \devicename…  in a web browser, it does a DNS query to find the IP address associated with the name.   If it can’t find it, it’s not going to work.

What happens if you try this?

\devicename.local

Example:

\mybookliveduo.local

It depends where I type \mybookworld.local

  1. google chrome says ‘page not found’…

  2. if I type the command into a folder it gives me the list of shared folders…

Yep, I have them backwards above.  In a browser, you’d use

//devicename.local

(Slashes in the other direction.)

By the way, why would you use the name mybookworld  when we’re talking about a  My Book Live Duo?

If I type //mybookworld.local in chrome it sends me to google…

I use this devicename because I had previous settings on a older device.

It sounded easier to name the new device exactly the same instead of changing settings on plenty of other devices… :wink:

Yeah, then there’s something wrong with mDNS either on your PC or on the Duo…

//bignas3.local

…immediately connects to my Duo.

You can check to ensure that the mDNS service is running on your Duo by connecting via SSH and issuing:

ps aux | grep mDNS

 and ensure that there’s a line that looks like:

root (blah blah blah) /usr/local/bin/mDNSResponderPosix -b -f (blah blah blah)

 By the way, in order for it to work, both the client (your PC) and the server (the Duo) MUST be on the same IP subnetwork, as mDNS uses broadcasts.

Thanks for your suggestion.

However, I have actually no idea how to connect via SSH to my hard drive.

Any suggestion?

Consider that I am a windows8.1 user and my WD has a static IP

Thanks.

Francesco

Search the forum… there’s dozens (if not hundreds) of tutorials on enabling and accessing SSH.

Hi there. I tried connecting via ssh and issuing the command you suggested.

Here is what I get back

root 4281 0.0 0.8 3776 2112 ? Ss Apr03 32:41 /usr/local/bin/ mDNSResponderPosix -b -f //etc/nas/mDNSResponder.conf -P /var/run/mDNSResponder. pid
root 15528 0.0 0.6 3648 1664 pts/0 S<+ 14:44 0:00 grep mDNS

Any suggestion?

Nope, not at this point…  that shows that mDNS is working fine on the drive, but not on your PC.

Wouldn’t have the first idea where to look on the PC…