Networking NAS Frustrations - I don't think this will ever get solved


No matter what options, settings I tried I cannot get Windows 8.1 to communicate with the NAS.  

First, there are some files that I put on the NAS that are not showing on the NAS, I hope there not gone forever.  I haven’t deleted anything; I’m hoping not.

Let me explain further.

That is just one of the problems; this is the MAJOR PROBLEM.

I have disabled HomeGroups in Windows 8.1; though Windows Services , both HomeGroup options disabled, why, because the problems it was giving, literally no one, as in more then eight people, knew the answer as well it was slowing down FireFox when browsing, and it was not helping with being able to read any files on the NAS. Since no one knew how to stop the problems it was causing, I had to disable.

Two computers, one, Windows 7, the other, Windows 8.1 are using workgroups instead, both have the same workgroup name. 

I can access the NAS though it’s IP address on both versions of Windows, no problems, I can see only the folders on the NAS with both versions of windows, I cannot see any files.  I am using a gateway modem, not a router, instead a gateway modem, there has been major confusion with what is the difference when getting help from others online.

HomeGroup is disabled in Windows 7 Services, but Control Panel > HomeGroup tells me that the computer belongs to a HomeGroup ? 

System Breakdown of what is happening when one version of Windows tries to communicate with the other;

Windows 7

When trying to access a shared folder that exists on Windows 8.1, I get the following error;

Windows cannot access \Name_of_PC

You do not have permission to access \Name_of_PC\Name_of_folder.  Contact your network administrator to request access.

I have tried, and tried as I might, to give the folder that exists on Windows 8.1 access to Windows 7, I’ve made no progress, Windows 8.1 won’t allow me.


When trying to access files within a folder, but not all folders on the NAS, I get prompt for a Network password, only if I restart the computer.  Since I have two users, one of them being the Administrator, I simply enter in the user name & password of either user and I have access to the files, except as I mentioned earlier;

First, there are some files that I put on the NAS that are not showing on the NAS, I hope there not gone forever.  I haven’t deleted anything; I’m hoping not ?

When I enter in the Network user name and password for other folders on the NAS, I strictly get; location currently not available ? The folders I can access have this structure, and I’m wondering if this is the reason for why some files I can’t see ?

[Folder Name]



— [series of letters and numbers represneting the folder ?]

That sums up, most, if not all the problems I’m having with Windows 7 and the NAS, now I will move onto Windows 8.1

Windows 8.1

First, if you remember, I disabled HomeGrouping on both versions of Windows, if you are asking yourself, what is the problem you were having with homegroups on Windows 8.1, it was a very odd problem, I was informed from someone online it may be a bug with Windows 8.1 networking, so disabling it and using workgroups is probably my best option, and so I did that, and quite frankly, I would rather stick with workgroups.  

Both versions of Windows has the same workgroup name, as I believed I mentioned earlier in this message, and if I didn’t, now you know :slight_smile:

As well I mentioned earlier in this message; I can access the NAS control panel using it’s IP address on Windows 8.1, and I can see the folders on the NAS but I can’t access the files.  

Windows 8.1 sees the EX2 as a storage device, including the gateway which it labels as the Network Infrastructure, as well Windows 8.1 sees Windows 7; when trying to access any folders on Windows 7 by clicking on Networking > Name_of_Computer in Windows explorer;  this is the error I receive;

\Name_of_computer is not accessible.  You might not have permission to use network resources. 

That is the only error I get, preventing literally everything to do with the NAS or shared folders etc. 

That conlcudes the problems on Windows 8.1


 I can access the Internet on both versions of Windows, but I can’t share folders or access files on a NAS, or map a directory folder on the NAS as a drive in Windows 8.1.  I have tried, I swear everything more then twice on Windows 8.1 with no solution, at times I could’ve swore I was going in circles.  I’ve thought about contacting Microsoft, then again, not  sure how deep this problem is, maybe the user groups and what is to be shared is just a complete mess and needs organization, at this point, it’s anyones guess.

Finally, how do I have the EX2 connected, simply.  The network cable is connected to the gateway, the gateway is connected to the Windows 8.1 box, the Windows 7 box is connected by network cable to the gateway, or wired modem , so it doesn’t lead to confusion, and that’s it.

I haven’t read most of your post. I just read a little bit.

My only recommendation that I would give based on the little I have read is to buy a router and connect it to your gateway modem. Then connect the EX2 to your router. I do not have, nor used gateway modems before, so my advice may not be correct…but I wonder if that’s behind some of the issues. Unless your gateway modem provides routing capabilities…then of course another router would be redundant.

As far as I’m aware, my gateway modem, does not have routing capabilities. 

If anyone has experience or knows whether or not this is the problem ?

Reading the entire post does give full information :slight_smile: I know it’s long, from forum experiences, not pointing a finger at anyone on this forum, just saying, if your explanation is weak, people complain, once your explanation is deep, most people don’t read it, you can’t win from losing on forums, then again, there is language barriers, you can’t win from losing.

I’m getting more into a rant, I want to keep on the subject :slight_smile:

The best way to check if you need a router or not is to plug the EX2 directly into the win8 pc and see if it does what it should do

I followed the suggestion of plugging the EX2 directly into the Windows8 PC, and it didn’t work, in-fact the internet stopped working, until I reverted the connection and let windows fix the problem.

I did make a minor step with homegroups, as I felt there was no where to turn but to try to get homegroups working once again.  It works, the homegroup sees the other computer, but every second, yes, every second, when you click on the homegroup icon in windows explorer, the window to the right changes from the name of the Windows 8 computer to immediately No other homegroups PC’s are available right now, that happens every second, I can time it, it switches every 1-2 seconds between the name of the Windows 7 computer to the error I posted a few words back.

Sharing anything drive on the EX2 so it can be accessed on Windows8, same as it always has been, I don’t see the drive on Windows8. 

Mapping the drive on Windows7 works flawlessly, except, I have a few files that I know I didn’t delete but are not showing up, and I have transcoded folders?

As well I can’t share any folder on the EX2 because it’s listed under the user nobody and it’s restricted to that users control for which I don’t have a password for ?

Maybe this will help, i see that alot of WIN8 pc’s have problems with nas devices, but no solution from WD…wierd

Can you access the hard drive via its IP address in Windows Explorer? Please try to modify the following registry on Windows 8 for a test.

1 - run regedit

2 - locate HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/Windows/CurrentVersion/Policies/System

3 - create a new DWORD entry with the name EnableLinkedConnections and value 1.

4 - restart your computer

The problem got resolved, WD came to the rescue although there still lingers a smaller problem with Windows which I was able to resolve.  :)