Networking issues with MLB

Hi all,

I was wondering could someone help me. I think MLB is faulty but I just wanted to make sure I’ve tried everything. It has been working fine for the past couple of months ( excluding the slow transfer speeds) I unplugged it and when I connected it to the network again the device could not be found. The device only shows the yellow light and does not go blue or green. I tried to reset the device at the rear holding the button for longer than 4 second and it didn’t reset.

Can someone shed some light on this please?


If the Yellow light in the front is flashing, it means it cannot find your network.

If the yellow light is SOLID, that means it’s still trying to load the OS.

If it stays yellow for more than 10 minutes, that’s a problem.

Did you remember to shut it down before you unplugged it?

Yes the yellow light is solid.

Yes I did shut it down, The only worry I have it when I used to log into it at interval there would be a lot of notification warnings to say drive diconnected etc, I always thought it was odd but considering what has happened there might of been an underlying issue.

Is there anything I can do to fix the OS? I find it odd the reset doesn’t work. Would the files still be safe on the hard drives?

Reset button has only a specific use case:  To restore the default passwords and return the network configuration to default.  It does nothing else - but it has to be fully booted for the reset button to do anything.

Consult nfodiz’s de-bricking guide for more info on how to try to recover your MBLD.

1 Like

Thanks for your help. I’ll give it a go and report back