Networked WD External Hard Drive no longer accessible from Live HUB

I have a 500GB WD hard drive connected to my router. I have been transferring files to & from this & between my Live HUB & my laptop for over a year. Aside from an occasional restart if the drive dissapears I’ve had no problems…

About a week ago 2 things happened. First, I installed Windows 8 on my lap top & second, I updated the Firmware to the latest version on my Live HUB.

Since then I cannot access the hard drive in the same way I could before across my network & it is not visible at all on the HUB. My suspicion is that this problem is Windows 8 related. That said, I connected the hard drive directly to the HUB & it showed no media present (or words to that effect) on the TV screen. I checked I hadn’t accidentally deleted everything by connecting the drive straight in to my lap top. Tried a couple of system restarts on the HUB & on my router, but no change…

So, I’m now thinking there may be a problem with the last WD Firmware upgrade.

I have a fairly limited technical knowledge, so either way any help or advice would be greatly appreciated.



Have you tried connecting the drive directly to the computer?

Thy to download the firmware here

it will give you the list of all the firmwares.

Choose the firmware that used to work, then download it to a usb then connect it to the live hub and try to update it manually.

Yes, fine when connected to the computer. Haven’t tried older Firmware yet because I’m thinking the problem is (primarily at least) linked to Windows 8.

Hoping someone out there can advise me on that, but thanks for your suggestion. I’ll give it a try…