Network Shares

This is just beyond frustrating so im turning here for help. I bought a WDTVLive yesterday based on seeing how my friends WDTVLIVEPLUS worked. Could not get the network share function to work at all so I called the support number and after ensuring twice that I had set everything on my computers end correctly was advised to return the unit to best buy as it was probably faultyand it would take 15 days to get a new one set from WD. Go to best buy…no more units on hand. So I figure ok I’ll get my buddies box and try to trouble shoot some more and see if the box is faulty or my customer support is faulty. Wouldnt you know it the customer support was in fact in correct and heres why:

Currently I can access network shares through my friends WDTVLIVEPLUS = my computer is set up right On my computer I can see both the WDTVLIVEPLUS and WDTVLIVE = my computer is set up right WDTVLIVEPLUS can see and acces local storage on WDTVLIVE= New box not faulty WDTVLIVE can see and access storage on WDTVLIVEPLUS= New Box not faulty

Call back and citing an obvious software issue not hardware issue I was advised to rollback the firmware. So now instead of running 2.01.86 I am running 1.16.13 and guess what…the brand new day old box running on god only knows how old firmware will still not see my  bleep  computer, yet the 6/7 year old box does fine. I have tryed with everything on a wired connection which required getting ahold of a 75 cat cable and I have tryed with it set on wireless.

Can some one tell me what I am missing or any additional steps to try and trouble shoot this so I dont have to call what is obviously a completley inept customer service line since I figured most of this out on my own already Im just at my wits end. Here are my computers specs: Win7 Home Premium SP1 and Netgear WNDR3400 router.

Help me internet your my only hope.

Make sure your WORKGROUP names are identical (NOT HOMEGROUP).  Then check out this sticky,

1 Like

Thanks for the help I didnt get a chance to get back on here but I ultimatley found the problem and it was the auto network set up feature not grabbing the same subnet mask ashe pc. Once I figure it out and got them to match it worked as intended. Thanks for  your in put.

chairmangorilla; Can you go more into detail on what you had to do? I’m having the same problem with my new wd live tv media player.