Network Shares

Router sounds good.  Well, I am outta ideas for now.

Hmmm,one more:   did you set router to defaults, and re-do your setup?  Have you got the latest firmware for the router? 

I’ll try reworking the router settings and look for a firmware update.  Who knows, it might work.  Thanks for all your input.

Unfortunately it seems to have much less to do with master browser then the wd ability to see devices connected to the router.

My boxee box, mk802II and AVerLife ExtremeVision Media Player (very dumb device) all see storage fine.

If say a NAS goes into sleep mode or a drive spins down the wd seems to forget it still attached.

I think the wd qauying of the router and its sensitivity for storage response times is just set to high leading to it assuming its gone.

Depending on the router and the firmware this can become somewthing of a major issue.

Consider that I have a WD Live Plus with two 2TB drives attached for over two years, and these drives go into sleep mode after 5 minutes of non-use.  When they’re asleep, I can still see these drives on my network, access them from any of my PCs (or a second Live Plus) , and they spin right up then and when I start to play something from them via the Live Plus.  This has been the case using two different routers during this time that create the home network.  So, it IS possible for things to work.correctly. 

The “problem” is not with a (properly working) WDTV, but from something external to it.  Maybe the fact that my attached drives are self-powered and not by a USB port, help – I would not know for sure, except that when I did have drives connected that were USB port-powered, things still worked correctly.

Wish I knew how to help the guy with his problems, and at this point he needs to contact WD support directly, as it seems he has exhausted his chances fo success in the user forums.

No its the wd.

I have two nas and a main computer with three large shared drives and it has a issue with loosing drives.

This is the only box i have that has this issue and its clearly affected by router firmware.

Which very likely means its quaying the router incorrectly or simply not waiting long enough for a response.

It seems the larger number of drives the more pronouced this issue becomes.

A reboot fixes this and likely because it takes longer to do the check for harddrives due to bootup.

Now you weigh this against the fact that ever other device i have see’s ever drive without issue and things become very clear.

   its clearly affected by router firmware.

So, why do you still insist it is the WD?  I told you my system works PERFECTLY – and has with two entirely different routers, so if it is router firmware as you say, either the guy, or you, have a “strange” router that affects the WD in weird ways.  Or, in the case of this guy, he just might have a new WD that is defective, so I suggested he contact WD support while he is still entitled to free support… 

Your not looking at this very logically.

First the issue isn’t affecting other media players and you totally missed the point about routers firmware affecting the nas.

The router firmware basically responds the same in most cases with some responding faster to requests then others but these minor differences shouldn’t affect a media streamer.

In all the but wd it doesn’t but the wd clearly is over sensitive to these minor differences when it shouldn’t be.

Merely because you setup runs fine with a limited number of drives hardly means much when you compare it to the fact that so many others are having issues.

Nas boxes also primarily run on nfs which responds faster the smb setups which a lot of people are using here.

The most important fact though you missed is that Wd has admitted there is a issue and they are looking into it.

This is purely firmware related and is not present in early firmware’s.

I love the box its works great but its not perfect.

Magnus33 wrote:

No its the wd … which very likely means its quaying the router incorrectly or simply not waiting long enough for a response.

I’m not sure what “quaying” means.

But I have 5 NAS boxes on my network… 2 QNAP and 3 WD NASs, totalling almost 30 TB of storage across 14 disks.   None of them have this issue you describe.  If they’re “sleeping” when I try to browse, the WD hangs while the disks spin up, and then everything proceeds normally.

Magnus33 wrote:

Nas boxes also primarily run on nfs which responds faster the smb setups which a lot of people are using here.

Run on NFS?  No, I don’t think so.  NFS is just another network  access protocol like Samba.  Many NAS boxes run NFS *and* Samba.   But I turn NFS off completely on my QNAPs because NFS is inherently insecure compared to Samba.

Ok one last time for people apparently no reading the forums here.

The missing shares are firmware related and doesn’t showup in early versions of firmware.

Sec WD itself has acknowledged this issue and are working to correct it.

Are you following me at this point?

The company has admitted there a issue with the firmware in regards to missing shares and going back to older firmware’s fixes this issue.

Short of putting up a neon sign and getting line dancers it would be hard to make this anymore clear.

The COMPANY itself has admitted the issue is there and OLDER firmware fix the issue.

Also if you actually read through everything by now you know that the issue primarily is affecting windows share as opposed to actually dedicated hardware for sharing.

As for what  “quaying” means.It means the spellchecker is a tad hit and miss here and I didn’t catch that one.

Of course you can go right ongoing ignoring these facts and blaming  everything else.

Just to let you know though that somewhat odd behavior given the situation.

Now can we stop this nonsense and get back to the issue which we where discussing.

Well, I updated my router firmware and rebooted everything.  All worked fine until my pc went into sleep mode (even though the pc wasn’t the master browser this time, the live hub was).  I still don’t know why the master browser assignment keeps changing.  Like I said earlier, boot order doesn’t make a difference on master browser assignment (at least in my system).  When I woke up my pc, neither bedroom live plus box would access network shares, but the living room live hub (where all the storage is) could access network shares.  I mapped my network on my pc and neither bedroom showed up on my network. I ran the WD discovery program again and everything worked after that for now.  It seems so random…

Side note:  I mentioned this earlier also, but my system can run without the pc even turned on (there is nothing stored on the pc) so how could this be a windows problem?

    As for what  “quaying” means.It means the spellchecker is a tad hit and miss here and I didn’t catch that one.

This word had me baffled, too.  So, what word did you intend to type; “queuing” perhaps?

Sadly yes but with both my hands in splints awaiting surgery I tend to use spell check more often then I use to.

Unfortunately spellchecker isn’t perfect sometimes and I missed that mistake.

The issue it self is hit and miss depening on your setup and hardware.

They know where the problem is and have aknowledged that but its still a question of when they are going to fix it.

As we all know wd hit and miss on fixing problems to so its a waiting game.

Fortunately older firmware don’t have this issue but you do loose a couple of the new features going back.

For myself it seems to forget one share on a nas is still there but another share on the other drive isn’t

Rebooting gets this back of course and has only been a issue in the last couple of firmwares.

Its no longer a question of what casuing the problem its just a problem getting them to fix it.