Network Shares suddenly stopped working on my Live and Live Plus

About three days ago I could no longer access my Network Shares through my Live or Live Plus.  Media Servers show  everything on my network, but not on Network Shares.

Nothing in my system has changed ,

i even set the computers back a week in case there was something going on there. Plus I did deactivate all my antivirus protection as well.

My connection is ethernet wired and I am running Windows 7 64bit on all three of my computers and it won’t see any of them in Network Shares. All my other devices and computers see each other on my network no problem. But since the weekend neither of my WD’s will pick it up !


Not that I can help but I have the same problem.  No updates between it being able to see and then  not see the PC with media on.  I do have an Iomega Storcenter that I don’t hold media on and it can see that.

Checked all settings, turned off homegroup eventhough I wasn’t using it, reset router and PC- nothing.

As you say, all PC’s see each other.

See if this tutorial for troubleshooting helps:

hi there

also try this : rj45 cable is normally plugged in certain port - change it, simple as that. Just change the place you normally hasve plugged rj45 cables. Reboot then , check and back into normal places agin.

revert to say if that worked


pawson [usb 3tb and nas 2tb,wireless and wire,win7, nat , dgt company router - all works quite nice]


In regards to the RJ45 connection, my WDTV is on a Cisco Wireless Adaptor.

The PC’s are all wired (PC One, PC Two, Iomega Storcenter, Brother Printer)

My Laptop is Wireless.

All PC’s see each other in windows networking and the WDTV as I have it as visible and can access the user name screen, but when I net view from PC One, Two and the Laptop I can only see the Iomega and the Brother Printer (this normally shows up in the Shares too).


I don’t get it, I haven’t changed anything!

Read Tony’s link.  When I had this happen, it was because my wifi router was winning Master Browser elections but was configured in such a way that it only saw itself and one other PC on my network.  In my case I have a linux box on my network where I run Samba and was thus able to configure it to always win Master Browser elections and that solved the problem.  If you only have Windows machines on your network, it’s going to take some luck with registry tweaks, because there’s no “always win elections no matter what” configuration value.

(to be fair, there’s no such config value for Samba either, but elections are based on a version number and you can set that number to its max possible value in Samba.  If you do that, the only possible conflict you could have would be with another Samba server that’s set its version to the max possible value)

 Sounds like a share issue.

1. Unshare all shares. Reboot all devices connected on your network.

  1. Recreate your shares again.