Network Shares shares the entrie hard drive


#1

Hello All,

Just got a WDTVLive Hub and like it so far but I am a little confused on the Network Share Folders.

I have a Win 7 x64 wuth all my media on it spread across 3 hard drives. All the folders are set to share across the home network, there are several on each drive. I use Windows Media Center and Media Browser plugin but as I have an older TV in the basement I cannot use my laptop to just plugin via HDMI. So the HUB seemed to be a good fit.

When I use the HUB and view the Videos, I get my "library "folderrs. In Music I get “Users” Why is this? The only Folders shared are the ones containing my media. In both of these case I have to navigate through each and every folder to get to the music or video file. For the DVD rips I have to select the actual VOB file which seems strange.

Shouldn’t it just play the movie when I click on the Movie folder instead of going into the VIDEO_TS folder then selecting the VOB? I must be doing someting wrong.

Breakdown:

HTPC Drive C: Movies, TV Shows, Home Movies, Concerts, Pictures

HTPC Drive D: HD Movies, Movies, PodCasts, Movie Trailers

HTPC Drive F: HD Movies, Movies

My PC Drice C: Music

Media Sharing is enabled for all devices across the network.

Includes:

HTPC

My PC

Family PC

My Laptop

PS3

Firmware version 2.03.24.

I tried using the Media Library but it was indexing my entire hard drive and not just the media folders. Turned it off and reset as it too made me navigate through each and every folder to find the movie/video/music file I wanted.

How can I get the HUB to only display the folders that are shared and not the entire dirve? I tried setting up an additional account and that failed as well.

Any help or direction is greatly appreciated. I like the device - just need to get it working the right way.

Thanx,

Daniel


#2

Maybe I am confused about what you’re describing.

For one thing, in Windows, you cannot have the same share name on multiple drives.

So if you you have a folder in Drive D named “HD Movies” and SHARED as “HD Movies,” then the folder in Drive F that is also named “HD Movies” CANNOT be SHARED as “HD Movies.”   It has to have a different share name.  The “SHARED NAME” is not always identical to the folder’s actual name.

Second, it should NOT make you go inside the VIDEO_TS folder to start a DVD, as long as the DVD is fully compliant (all the IFOs / BUPs / VOBs are there).   When you do this, are you getting full DVD menu support?   If not, that could be a hint of something else going wrong.

That MIGHT have something to do with Media Library being OFF, but I’m not sure.  I’m thinking it might require Media Library to be ON to ensure it indexes the DVD folders correctly.

The Media Library will scan EVERYTHING that the Hub has access to.   If you password-protect the NON-MEDIA folders, or assign a separate USER as the OWNER of those media folders (and give the MEDIA a different password) then that won’t happen.

As to why you’re getting “Library” folders and “Users” folders, it’s because you have PUBLIC SHARING ENABLED in your Win7 box.

Also, if you enable Media Library, and allow it to compile, it WILL NOT show folders that don’t have the correct type of media in them.

In other words, a shared folder that has no VIDEOs will NOT show under VIDEOs, but WILL show under MUSIC if there are music files in that folder.


#3

Thanks for the reply.

I use the above set up/naming for the folders and WIn Media Center finds all of them without having to set shared names for each folder. Are these supposed to be set up as Network Drives? Or am I mis-understanding - comparing apples to oranges (WDTV to WIn Media Center)?

As for the DVD playing - I only rip the movie. No menus, no extras, no previews etc. Could that be why I have to start the movies from the VOB? Seems odd because Win Media plays them fine - no need to select the VOB.

When you say “public sharing” on my Win 7 box what do you mean exactly? Do I need to turn off sharing media with everyone? Or is it someting I missed entirely?

I’ll set the owner of all my media folders to a single user and re-scan the media library.

I’ll just move all of the music on My PC to the HTPC since I wanted to do it anyway :slight_smile:

Thanx for your help and explanation,

Daniel


#4

I set the Public Sharing to be OFF. But I am still seeing the “Users” Folder on the HUB.

I can see most of my media from the HUB - but one folder/drive ( called Media2 ) the HUB tells me there are no media files in it which I know to be false. There are four sub-folders in it that all have media.

I also set the WDTV user as the owner of all the media folders on my HTPC but the folder of HD movies as I only have a wireless network at home. This folder of HD movies still shows up when using the WDTV user/password even though the WDTV user does not own the HD Movies folder. So it would seem that setting the WDTV user as the owner had no effect on what is shown on the HUB when I set up the Media Library.

Why can’t I just tell the HUB what folders to select from in its interface? I’m getting fairly frustrated with this product and how un-user-friendly it is to set up. This should be a very simple process of telling the HUB what folders to aggregate into a media library.

I really should not have to set new owners of folders, new users on my network or disable public folder sharing to get this to work correctly and display only media files/folders. This product has promise but without any real instructions it is very hard to get it set up and running. This should be a simple process.

I’m at my wits end here. Any help is greatly appreciated!

Thanx,

Daniel


#5

So I had some Owner/Sharing settings that were not correct and The Media Library seems to be indexing all of my media.

How Can I check to see if it is still indexing or not? Only part of the Movies in the folders are being displayed in the HUB, starts with letter “H” I am pretty sure this is because it is still indexing but need to know as I tried to watch a movie in the Media Library and it shutters the whole time. Same movie streams fine to all other devices - so probably the HUB is still indexing.

I am still really unsure of what I have to do to get both my “Movies” folders shared. I have one “Movies” folder on Drive D ( none on drive C as I previously stated ) and a “Movies” folder on Drive F. Do I need to rename the Drive F Movies folder? I cannot find how to change the “SHARE NAME” for these folders. If someone could give me a bit fo direction that would help.

Is there anothe rway to include the additional “Movies” folder without renamiung it? I have Win MEdia Center and a plugin that is set up to use my current folder structure and would like to not have to change it just for the WDTV. But will if I have to.

Thanx again,

Daniel


#6

dkmojo wrote:

I am still really unsure of what I have to do to get both my “Movies” folders shared. I have one “Movies” folder on Drive D ( none on drive C as I previously stated ) and a “Movies” folder on Drive F. Do I need to rename the Drive F Movies folder? I cannot find how to change the “SHARE NAME” for these folders. If someone could give me a bit fo direction that would help.

You have to rename the SHARENAME not the Folder, the SHARENAMES have to be unique to work this way.

The SHARENAME is defined there where you actualy make the Share available, depending of the System rightclick on the Folder and Sharefolder or somthing like that, there the Name of the Share is defined. But its strange that you can make two Shares with the same Name anyway, because as i know normaly WIndows will complain if someone try to make a second with the same Name?!

Also making available only these Shares for everyone and deny access for everyone for all other Shares you may have, should hinder the HUB to actualy see and/or index them.

And concerning the VIDEO_TS Problems, i suggest to make ISO’s eg. put the Folder with the DVD-Structure in one ISO-FIle, this is not only cleaner but also seems to work better, then you simply play the ISO instead of navigate trough Folders, think its faster and also means less Folders and Files to be indexing too, but its only a suggestion.


#7

Thanks, I actually completely missed the SHARED NAME in the settings. Not to mention that the folder I was having issues with was not actually shared. I keep forgetting that since all the other media in my home is controlled by Win Media Center all I have to do is Join the HomeGroup and that machine is good to go - with Share Media with Everyone enabled.

As for the .ISOs, I would have to convert about 300 movie rips to do that :(I’ll have to think about it. How do I convert the VIDEO_TS structure into ISOs? DO I need to re-rip? Or can I just convert like I do with my Blu-Ray discs to .MKV?

I no longer have to select the VOB files but still have to select a VIDEO_TS folder then I get to select the movie. What is strange is that I see the Movie folder ( with DVD cover image not sure why that shows up as my current meta data is controlled by MetaBrowser for Win Media Center ) then I get a VIDEO_TS folder then the Movie FOlder with Cover Image again. This is the one that plays the movie. Its not all bad.

So I probably have some tweaking to do to use both the WDTVLive HUB and my current use of Win Media Center. I like the interface of Win MEdia Center but cannot theme it myself as I don’t know C# or C++. But I do know some XML and theming the WDTV looks to be a lot simpler :slight_smile:

I need to look into the ThumbGen program and how it differs and is the same as MetaBrowser. Hopefully I can re-use some of the same info I already have.

All in all I really like the WDTV HUB, just a bit of a learning curve is all :slight_smile:

Thanx again,

Daniel


#8

dkmojo wrote:

 

As for the .ISOs, I would have to convert about 300 movie rips to do that :(I’ll have to think about it. How do I convert the VIDEO_TS structure into ISOs? DO I need to re-rip? Or can I just convert like I do with my Blu-Ray discs to .MKV?

No, No, you don’t need to ReRip or convert anything here, its more like if you Zip Files. Its enough to select the Folders at once and build an DVDISO of it, thats all. If you Rip the DVD’s directly to an DVDISO its also the same, but its also possible to make an ISO out of the existing Folders too, so no need to put in each DVD and ReRip it for that. Dunno, but perhaps there is even a Tool that support Batchbuilding of ISO’s, this way it would be easy to build all together at once.

Every DVDBurn Program can do this Job, move the Folders like you will if you would burn a DVD and then simply save it as ISO, thats all. But there are other Tools for only building ISO’s also where you simply select the Folders and save the ISO, this is a simple Job, no need to convert any Files here.


#9

I found DVDShrink and uses it real quick on a movie. Seems simple enough.

I still get stuttering in the stream, no audio or broken audio. Strange as the WDTV HUB is using the exact same wirless USB card as my HTPC and I have no issues streaming to any other device.

I’ll try setting up a wired connection and see if that helps. At least I can tell if it is the Wireless card or not.

For some reason about 12 movies are not being alphabetized. They show up before the “A” movies and then everythign else is in the right order. Any ideas on why this happens?

Thanx again,

Daniel


#10

Streaming works across the Wired connection. Very strange as the USB card I am using is the same as i use with the HTPC and its an approved Wireless Card for the WDTVLive Hub.

Both ethe VIDEO_TS and ISO files played fine so I know its not the VIDEO_TS I was having problems with. I still have to select the VOB file to play, but that may be due to re-compiling the Media Library.

Now I have to figure out how to wire it in without running wires alll over my house :slight_smile:

Thanx,

Daniel


#11

OK, I really cannot figure out this folder sharing and ownership issue.

Here’s what I have issues with:

A folder Called “BD” contains all my HD Movies. It is not being shared and the WDTV user is not the owner of it. It still shows up in the HUB. Why?

My Drive D is Called “Media2” it is not shared and still shows up. Again Why could this be? The Folders within it that are shared display fine as they should.

The “Users” folder still shows up in the HUB and I have disabled Public Sharing. Not sure on this one.

A folder called “Media” displays but is not shared and the WDTV user is NOT the owner of it. The TV and Conerts in that folder are shared though and work as they should.

How can I refresh the Media Library? So that everything is updated?

This has got to be something really small.

Thanx again,

Daniel


#12

It doesn’t matter if the VOB or the ISO is played, both are the same files, the only positive effect on using ISO’s is that verything is bundled in one File while the playing the VOB’s means haveing Folders with many Files in it, thats all.

And concerning the stuttering, it seems the wireless is to slow then, this can have many Reasons, like bad Drivers, slow USB on the Hub or even the Location of the Hub and Obstacles between the USB-Dongle plugged in the HUB and the WiFi-Accesspoint or the HTPC hosting the Files.

Its dependent of the Accesspoint but some offer also special Option for streaming Videostreams over Wireless, perhaps yours support that too, if so try enabling it too see if its better then. However i allways prefer a good Wireing over Wirelessconnection in House, because of the Elektrosmog it produces.

And with a little thinking on how to place Switches, the Wires can mostly be reduced to only one Wire accross Rooms eg one Switch beneath all the TV-Devices and another one beneath the PC’s means only one Wire between the two Switches which certainly don’t bother to much.

I have Wireless too here, but only use it for iPhones, iPads and such Devices, everything else is Wired, i also choiced CAT6 SSFTP Cables from the beginning, costs a bit more but is certainly worth to invest on it, because i wire it once and then never again have to be concerned about possible Problems because of bad Shielding and such ■■■■. For most Situation even CAT5e UTP ist enough but as soon as these Cables comes in the near of Powercables and other Elektroradiation it can be problematic, so its better to invest once in good SSFTP Cables and be on the secure Side and never again needed to think about where the Cables passes.

Also if using Wireless, its important to think about the others using Wireless too, if there are 20 others using Wireless in your Hous or beneath you, then Problems arise and sometimes only using 5Ghz while other are using 2.4Ghz will really help. For that Reason i have an Dual Band Router, if ever i get this Problem i switch to 5Ghz, but i don’t use the Wireless anyway so much, so i don’t really care for now.


#13

dkmojo wrote:

OK, I really cannot figure out this folder sharing and ownership issue.

 

How can I refresh the Media Library? So that everything is updated?

Hmm, perhaps there is still the Read Access to Everyone, if so remove it or deny it on all these you don’t want the Hub can see or access them, and give only to the WDUser Access to the specific Shares, then enter the WDUser Username and Password on the Hub also. The local Ownership normaly does not matter on Shares, the Accesssettings on the Shares are the one controlling it not the Ownership.

The Media Library can be refreshed by shut down the Hub Completly and reboot it eg. press the Powerbutton on the Remote 15 Seconds or so until it shuts down then press again to start it. The other Way is to disable and renable the Media Library, seems to do the same then.


#14

Thanx for the info on Wired networking. My basement is not yet finished off so it should be no problem getting at least this part of the net work wired. Will need to figure out the first and second floor later.

Since I refreshed the HUB Media Library it no longer shows the “Media2” drive/folder. So that is good.

It still shows “Users” folder, and the BD folder. I checked and the BD folder is not being shared with the WDTV user, but is shared across the HomeGroup via media sharing. Could this have something to do with it?

I’ll check the read access again and see what happens.

Thanx again,

Daniel