Network Shares Not Switching


I hope someone can help, I have managed to set the Live Hub up no problem and can stream movies and access Network Shares. 

The problem is when I go to switch from one network Share to another it does not move onto the new selection. If I reset the Hub and when it reloads the new selected share appears.

The shares are connected to 2 NAS servers and I have no problem switching with my WDTV Live box just the HUB


The hub memorizes the last server used.

You can turn OFF “Auto Logon to Network Share” and “Clear Login Info” from the Network Settings menu.

Thanks for the quick reply, but if i am in the network share selection screen i would have thought i could select the one i want.

Are you seeing i must do the following to have that function

You can turn OFF “Auto Logon to Network Share” and “Clear Login Info” from the Network Settings menu.

Are you saying that you can select the share, but it just doesn’t show its contents?

For example if i have 2 shares, Drive A and Drive B.  I can see them both so i select Drive A, i can then browse the folders and files on this share.

If I then go to Drive B it goes to connect but then the screen shows the contents of Drive A, so  i guess it is not connecting to Drive B, but if i reset Hub i get to see the contents of Drive B.

As the original post the WDTV Live does not have a problem at all switching between the two. 

But I don’t understand what you mean by SWITCHING.    

If BOTH SHARES are on the same computer, and they are both accessed via the same User ID and Password (or lack thereof, if anonymous) then they should both display simultaneously.   

But if the shares are on two different SERVERS, or use DIFFERENT user ID and password, then what I said before is correct.

So, if you have something like:



then when you connect to SERVER, then after it indexes, and assuming you FILTER by FOLDER, then the first thing you should see under VIDEOS is two thumbnails that say:

Share 1

Share 2

and that’s it.


My set up is on two different NAS servers so like below, and are open to guest login and have no folder restrictions



Not sure why thought i have to delete login data to swap between the two?

You DON’T.   Just press the RED BUTTON, then pick Network Shares, then pick the server you want.

say i was looking at my media on \SERVERA\Share i then press the red button and can see all my network shares, I then  select \SERVERB\Share but when i am presented with the media browse screen I only see \SERVERA\Share media again.

Both NAS run twonky so i can see the media through that option but i want to use the network shares for the metadata in Movies

I’m not sure what you’re doing wrong.   All I can say is that it works fine for me.  

I have 5 different Samba servers; each one displays the correct content.  

Maybe it’s a problem with your MEDIA LIBRARY.   Do you have that turned on?

When you browse into the new server, the first thing it should do is pop up a message that says something like “The WDTV is compiling the media library.   Do you want to browse by Folders first?”  and give you choice of OK or CANCEL.

Media Library is turned on.

When i select say ServerA it ask for user name and password, i leave them as the default and click remember.  It then compiles the Media Library.

Same procedure for ServerB and it compiles the library.  If i try to browse videos back on serverA it lets me select it but displays ServerB folders again.  I can get back in if i clear network logins, but is scans media again.  

I have no problems with my WDTV Live selecting the different servers, but with the HUB I am having the stated problems.

I did some further testing and found it does not want to go to back serverA, i plugged a WD2TB (call it ServerC)Nas into the system along with my 2 QNAPS (Server A and B).  

If I follow the above I call Select Server A then B and C, and can select from C to B and B to back to C, but if i go to Server A it jumps back to B

If i clear network logins i get to get back into A but as soon as i swap i am locked out of A.

Would appreciate advice on how you get yours to work

Can anybody help me please with this bug?

I can happily switch from my local storage to the Network Share but it does not let me do as described above

Yeah, hopefully someone can chime in here…  I tried this last night:

I set up “Anonymous” shares on three of my five servers.

I was able to bounce back and forth…







I tested against a QNAP, My Book Live, and a Win7 box.

When you created the “Anonymous” share what was your user name as the QNAP has that name reserved allready.

Or did you just created a folder and give full permission, so no name or password needed, also did you click remember me on the HUB to keep the login details

Could my trouble be a server naming issue,  One is simply called MEDIA and the other Colins-Media.  The one called MEDIA is the on i have trouble with

Everything is running great apart from this so desperate to get it sorted, cant understand it as both my QNAPS are set up the same and all drives assigned to the HOME workgroup.  

I didn’t assign a name on the QNAP; I just marked the folder as “Guest Read Only.”

Yep, said Remember Me on all logins.

I doubt the names have any bearing; they’re unique, so shouldn’t be an issue.

I thought of trying to add a new folder on my QNAP to test the network share, it has the same  response as my previous problems.

What i have noticed is that when i try to switch to server A and it does not, if i hold the power button for 3 seconds and start the HUB again, it prompts me to login to Server A when i browse to vidoes.  

Also on the rare occassion i can swap from B-A but when I go to view a file says no content available, if i go to home screen and click Videos I am presented with Server B!

I have tried rebuilding Media Library but that has not worked and now the Movie Data i selected for all drives is gone, even though i can still see it in the Metadata folder!

Alright; let’s try to narrow this down.   Since you’ve already lost the metadata, this won’t hurt.


How does this affect it?

Turned it off and managed to switch between the two servers no problem.

Whats the next move please.

Turn it back on and see if the problem returns.

If it DOES, then:

 Are the share names the same on both servers?   Like



If that’s the case, then try a simpe change to the share name:



… basically anything that makes them unique.

It appears that the media library is what’s getting confused; not the SAMBA client.

Problem came straight back, once i switched it on.

No Share folders on the 2 servers have the same name.