Network Shared folders and metadata

Hi all,

I have two questions. First, I have ripped several DVDs with AnyDVD and for most of the movies, it displays them as one movie file (which is great) but for others it displays them as a folder with “movie name” and “VIDEO_TS” folder inside and so on. Do you know why it does this for some movies and not for others?

Second question: The DVD movies that the HUB does not see as one file but as a folder do not have the “Get Content Info” option if they are on a network shared folder. And having a jpeg inside the folder with “folder.jpeg” also doesn’t work under network shares. Is there another way to get metadata for these movies?

Thanks!

for part 1, you probably have it set to EXTRACT TO FOLDER or something along that line.  i use DVD DECRYPTER or DVDFAB, and make sure i always “EXTRACT TO .ISO”, so it extracts it as 1 image file and usually 1 .md5 (verification file, which i delete). 

for part 2:  make sure the folder is named the same as the image file.  so instead of “folder.jpg”.  have your folder called “CARS” and your image “CARS.jpg” and keep it under 70kb.  not sure if that will work, as i alway rip to .iso.

if you feel like trying, give " FOLDER2ISO" a try.  it’s a simple drag and drop program to turn your movie folders into single image files.  *** but i find it easier to d/l from HEREsite and make sure you don’t d/l any toolbars or anything and select one of the MIRRORS on Right Side of the pg"  

Softpedia Mirror (US) [EXE]

Softpedia Mirror (RO) [EXE]

Richard,

I have ripped my DVDs as well (which saves a lot of space compared to ISO image of the whole DVD).

My structure is that the ripped files are in “MovieName”/VIDEO_TS, with the VOBs and such of course in the VIDEO_TS directory.

Now for the bug I have experienced with the Hub… When I move the movies to the HUB, about 20% of the time it correctly identifies the movie (names it after the “MovieName” folder, and do not show me any of the VOB files, except during the transfer of the VOB set (while they are not yet all on the Hub).

Unfortunately, the recognition of the structure is not done fully correctly, so for the rest of the movies, suddenly it shows all the VOB files instead, VTS_01__2.VOB and such. From loading up quite a few, I have found out that it seems to depend on the order in which the individual files arrive on the HUB, which depending on your copy method is usually quite random.

Here is my workaround so far:

  1. After all files are transferred to the Hub, I find all my movies with no information loaded yet by setting the Genre filter to Unknown. Limits what I have to see and do “Get Info” for.

  2. I then do “Options -> Delete” on the VTS_01_1.VOB file for each movie on the Hub. (Not necessary to delete the others (*02*, *03*, …)  from the list).

  3. I then re-sync the VTS_01_1.VOB file back to its position in the movies VIDEO_TS directory on the Hub. With the *01* file being the last one to arrive, the catalog software finally figures it out and switches the movie to the “MovieName” name, and eliminates all the VOB files (01, 02, 03) from the list of files.

In my opinion this is a bug. I like the fact that the Hub shows the VOB files until the whole set for a movie is available on the Hub. Allows one to see any failures/stray files. However, after the catalog software sees that the whole set is there (independent of which number in the sequence happen to arrive last), it should automatically remove the VOB names from the movie list, and insert the MovieName (the folder name that contains the VIDEO_TS directory). One should not have to assure that the 01 sequence file arrives last. (In my workaround by deleting it from the Hub and copying it in again.)

1 Like

Riddle, it might be a dependency on when the media library compiles.  Wait until everything is done, then turn the hub COMPLETELY OFF (not Standby) and then turn it back on to redo the media library.

Does that make it work correctly?

Tony,

When deleting VOB 01 file I see the library entries being changed as it happens (and the WD disk indicator blinking nuts while doing it). The library catches the file change, and modifies the library content.

As I run the sync to the Hub, I afterwards go into the library and see most (not all) of the VOB files shown as individual “movies” instead of the movie name holding each set. As the library seems to update on the fly when a file is added/deleted, I am not sure whether a total redo (reboot) would change things. Don’t remember.

I’ll test that when I get a chance.

Independent of which workaound is used to clear up the mess of VOB files, it is still too bad that the software does not figure it out on its own. It is most of the way there already. When I do the VTS_01* workaround, the catalog recognizes the full structure is avaiable and afterwards eliminates not only the VTS_01, but all the VTS files for that particular video from showing directly in the catalog. For some reason it just apparently depends on the VTS_01 file being last to arrive (or maybe a reboot as you say).

But that’s too bad. It should check whether everything is available and potentially clear it up after each VTS file arrival, independent of the order of arrival (if arrival order is really what confuses it).

Tony,

 I tested your suggestion of forcing a total rebuild of the catalog but shutdown/reboot. (Hold power more than 3 seconds to shut everything down)… It does NOT work.

a) The VOB files for that same newly added movie are still listed as individual VOB files (not as the named movie).

b) WORSE… Using the reboot option (even if it had fixed the VOBs) is not one I like. to use A restart of the Hub takes more than 11 minutes of rebuild, where the first 3-4 minutes it is stuck in the “Loading Mochi” screen with lights blinking, and the remainder it is just scanning 3 TB of data with the Recompiling catalog message showing. In addition to not fixing the VOB issue, the catalog rescan also caused it to lose information on about a hand-full of movies I had previously done “Get Info” for. It lost their metadata on the way for some reason. Fortunately only a handful. Not all 500+. :stuck_out_tongue:

The incremental update workaround of deleting and re-syncing the one VTS_01 file for each mishandled movie  still seems to be what works. Pain in the behind to have to do, but it works.

Hi Riddle,

That’s exactly what I’m experiencing. For some of the movies, the HUB sees them as one file but some appear as  “MovieName”/VIDEO_TS with the VOB files and all.

I’ll try your workaround to see if it also works for me. I’m really hoping it does because I cannot do the “folder.jpeg” workaround when the folders are on a network share (it doesn’t work there)

I agree that this is a bug and a very random one. I spent a lot of time comparing the folders structures of the ones that worked and didn’t work but had no luck. 

Richard, let me know what you see when you try it.

By the way, if you are having the Hub auto-sync from a network share, my case is somewhat simpler. I only let it autosync my music from a share, while all movies are pushed to the hub from the outside. I do not let the HUB handle it itself.

Hence I am in control over the sync. After i delete the VTS_01_1 file, I kick the sync off from my end, so the Hub is forced to take care of it, instead of potentially have to wait for the hub to detect and re-find the network file… :wink:

Hi Riddle,

It kinda worked but not the way I wanted it. The way it looks on the HUB now is “MovieName” folder and inside, I see the movie as one file. However, I just want the movie as one file without any folder. The reason I want this is because my files are on a network shared folder and “Get Info” doesn’t work the same way it works on files inside the HUB or on an external USB drive. On network shared folders, “Get Info” only works on files and not folders. So I cannot get the cover art to show up unless the file is outside a folder. 

It seems that if I want the movie to show as one file outside the folder, I need to copy all the VOB, BUP and IFO files from the VIDEO_TS folder and paste them on the “root” level with all my other movie files. However, this is ugly and it would only work for one movie as copying another VTS_01_1.VOB file will attempt to overwrite the previous file.

I guess I’m going to have to live with the movie as one file but inside a folder and not get the cover art for it :frowning:

Sorry, can’t help you there. I decided earlly on two things. a) Would not let the HUB use a network share directly for playing movies, and b) that I would not use the Hub’s sync function to move video to its own drives. I instead mirror files from outside onto the Hub’s own shared drives, so I am in control over the mirroring process. Costs extra disk-spindle for the HUB, but also means an extra backup copy of the content in case of disk failures (which happen fairly regularly in this house, I have more than 30 large disk-spindles running busily 24x7 for various purposes. Just lost a large disk-drive 2 days ago going through the warranty replacement process right now.).  Hurray for having live copies of all data. Never, ever trust hard-drives. :wink:

As it is, I now have 3 copies of all media content for extra backup security. The originating shares are on RAID1 (disk-mirrored) filesystems, from where the video content areas from various filesystems are then network mirrored onto the HUB drives giving me the 3rd copy. I spread them into alphabetical areas/directories (like 0-9, A-D, …) so I can manage which sections mirror onto which Hub drives. Plus, of course I have the original DVDs stashed away which is actually a 4th security blanket. :slight_smile:

Wait, when you say that the vobs all show up, are they showing up with the video camera icon next to it?    If so I was having this same issue.   I rip everything to 

/VIDEO_TS/

And 99% of the time the HUB recognized the folder name as the movie in a video_ts structure.   But very randomly (or so it seemed) I would have to go into the folder, then into the video_ts folder to get any movie info.   The issue turned out to be related to folders with ’ in the file name (the quote character).   for example I had The Devi’s Tomb, this move would not be properly recognized by the hub, I renamed it to The Devils Tomb, and rescanned.   The hub recognized it fine. 

Hope this helps.