Network Share suddenly stopped working

I have a WD TV Live downstairs and a WD TV Live Streaming Media Player upstairs. Both updated to the latest firmware, connected to the same Workgroup, and passed the network connection testing (able to connect to online service via my wireless router).

On the Streaming Media Player upstairs, I used to be able to access the network share of the WD TV Live downstairs and my laptop upstairs wirelessly. But all a sudden, my laptop disappeared under the network share screen a couple of days ago, and so did my WD Live TV downstairs yesterday.

My laptop and the WD Live TV downstairs can still communicate with each other wirelessly without any problems. But when accessing the network share / windows share interface on the Streaming Player, it just keeps searching and nothing showing up.

I have tried nearly everything after reading numerous threads on this forum. These are what I have tried:

  1. Reset to Factory Settings.

  2. Roll back to an earlier firmware.

  3. Re-do the network setup on the streaming player.

  4. Plug in a USB HDD to play some movies and then disconnet it.

Unfortunately, none of the above has worked. Can anyone please help with this annoying issue? It seems that I am not the only one that have encountered this problem.

Have you tried something simple like restarting the router? 

I have tried to restart the router many times, no luck.

However, last night I changed the workgroup name and everything suddenly started working. Very weird. Because the workgroup name was the same on all networked laptops and the WD TV Live downstairs. What I did last night was simply to change the workgroup name to a different one.

People stuck in the same situation may try my method.

Had the same problem.

Seems as though I had both an Ethernet wireless simultaneous connection to my network which caused a conflict with WD Live.  I disabled my wireless connection, leaving only my Ethernet connection.

Network Shares now works like a charm!