Network Share just isn't happening

I have read loads of posts in this forum, so I apologise for going over old ground, but I feel like I have tried everything and I’m still stuck getting my WD TV box to connect to my network share. If anyone feels able to offer advice I would realy appreciate it.

I am running VISTA on a pc which has a wireless connection to the internet.

I have an external drive on which I can see loads of movies and pictures when viewed from the pc.

I have right clicked on the external drive in my computer and selected ‘Share’

In the share tab I have clicked on advanced and selected a new share and called it WORKGROUP

In the network and sharing centre I have renamed my network WORKGROUP

I have also put, Network Discovery to ON, File Sharing to ON, Media Sharing to ON and Password Protection to OFF.

If I dissconnect the external drive and plug it into the WDTV box it sees the files just fine.

The connection on the WDTV box gets 3 green ticks and connection is no problem because the bbc iplayer etc work just fine. 

This is driving me nuts. I don;t know what else I can do. I really hope someone out there is able to help me with this.

Thanks for reading

First, don’t name your share “Workgroup.”  That’s a confusing name.  “Workgroup” only applies to the COMPUTER workgroup; nothing to do with share names.

Second, you haven’t mentioned what happens when you try to connect.

Finally, See if this tutorial for troubleshooting helps:


Ok, so name changed from WORKGROUP

When I click on connect to Windows Network on the WD TV box I get the orange circling arrow going around and arond and no computer name for it to connect to.

I did look at the tutorial, but I don’t really undersdtand dos commands or scripts and I got a bit confused.

When I ran the first cmd net view I got \DEB-PC but there was no remark with it

Running code nbtstat I get;

DEB-PC <00> Unique  Registered

Workgroup <00> Group Registered

Workgroup <1E> Group Registered

Deb-PC <20> Unique Registered

Workgroup <1D> Unique Registered

MS Browse <01> Group Registered

Then I tried the net view /domain

and I got



I don;t where to go to get the IP address so I couldn’t go any further than this, which didn’t really mean anything to me.

Hope it means something to one of you out there, thanks again