Network share issue

I just purchased a WD TV Live Streaming media player. I got it to detect my network via a wireless Linksys router, no problem. I’ve shared a few folders with media files, but the player does not detect it. It always says no content/storage found. I tested a usb drive and that works fine. I also tested youtube, no problem. The main reason I bought this deive was to stream media wirelessly from my PC. The firewall is set correctly. When I click on Video, Music, etc, I have a SMB option and a NFS option. Either one gives me the same error message. When I go to setup to add the network share, again it sees nothing even though it’s on my network and configured correctly. The firmware is also up to date. I also tried TVersity with no luck. Can you tell me how to set this unit up properly? I really want to keep it and not return it if I don’t have to.

Do you get the same error when you go to media server and click tversity?

How do I go “media server”?  If you are referring to the WD hub. it sees nothing.  I just used the WD Link Tool and it sees my hub.  I just set a password on the hub.  It’s not getting past the login for some reason.  No error here.  I’m sure this is some kind of network configuration setting somewhere.  When I try to login via the WD tool, it just sits there, however it created a desktop shortcut with the correct ip address, but when I try to double click it, it says I don’t have permission.  I can ping the hub successfully though.

Ok, finally got it working.  I went back and under files it said my previous content source had been removed (although I don’t remember doing that or where), but I selected TVersity as the new one and now I can see most of the media.  Thanks for responding.