Network share BROKEN after firmware update (1.05.18)

Updated my WD TV Live to the latest  firmware tonight (1.05.18), and it seems to have completely broken Network Shares, as in it refuses to find anything! It’ll sit there for minutes on end searching, yet it’s not generating any network activity anyplace. Tried both wireless AND wired, same result.

Any ideas? Internet based resources still work (Hulu, etc).

Same here! … when looking for Window shares (SMB/Cifs) just keeps spinning.

On a happier note NFS now works great without the delay and media library function too!

Have you tried following the instructions in the new product update? 

_ “After upgrading to the latest firmware, the Media Library entry for the NAS maybe lost. To add a share folder to the Media Library, press “Option” when highlighting a share folder and select the “Add to Media Library” button. Or, go to Setup/Systems/Media Library Manager for Network Share to add a specific share folder to the Media Library.” _

Give it a go.

Steve W

For what it’s worth, I applied the new firmware update, and my Windows 7 network share is working fine.  I did a factory reset after the update, though.

I have four devices and updated two of them only to find that they could no longer see other PC’s on the LAN.  The two devices I did not update are still finding Windows network shares and working fine, proof if it were needed that a bug has been introduced in 1.05.18.  If like me all your media content is on a PC or Server, then this is a critical issue.

Even more disconcerting is the fact that after rolling back the updated devices,  the problem still exists where it never existed previously.  Tried cycling the power and reset to factory defaults without success.

Have not yet tried changing the video source to a USB input and back to Network share.  Will try today and report if successful.

Updated mine last night.  Went to the settings section, added two folders from my Unraid Samba share, and all is (almost) well.  All the shows are there, but I’ve been having trouble since we had a power failure (already a problem before this update) making the metadata show up at the top of each BluRay folder.  If I drill into the stream folder, it shows up, but not at the top of the BD folder.

I rip using AnyDVD to BD folders.  The WD won’t let me choose a different playlist file (and frequently picks the wrong one) so some movies I have to remux using ClownBD.

Same here! No network shares visible anymore (from WinXP PC). Worked fine just 5 minutes before the firmware update. Tried everything that has been suggested here, didn’t help. Online services work. Other devices can still see the network shares.

Okay, weird thing,  now it’s working nicely. it’s seeing all available shares on the entire network now. I had hooked up a flash drive to watch a couple of things on it last night, disconnected it today to try a step posted here, and now it works like a charm.

Perhaps unplugging my flash drive fixed it? FW Bug possibly?

The 1.04 release had the same problem. Sometimes, I couldn’t find network share folders. But if I switched the source and came back, these folders were there again.

I updated the FW to 1.05 today. Everything works well so far.

I did the factory reset and it sorted the problem.

I tried that as well last night, didn’t fix it. Trying it today, unhooked the USB drive I had on it to try a solution here, well, didn;t have to try that solution, it’s still working nicely as I type this