Network share after Windows 10 Creators update fails

Hello,

I have used WD TV Live for many years succesfully.
Last week my Windows 10 was updated with the Creators update, and I cannot see the windows network share anymore.
I have tried everything, changed all options both at my PC and the WDTV Live device, however no success.

Has anyone an advice?

Regards, Geert

Hello,

Did you verify if the network discovery settings are turned on by going to “Control Panel\Network and Internet\Network and Sharing Center\Advanced sharing settings”?

Hello,

Yes, I did and everything is ok, nothing was changed.

Regards, Geert

Van: G_Rayn [mailto:wd@discoursemail.com]
Verzonden: maandag 5 juni 2017 22:14
Aan: geert.sanders@onsnet.nu
Onderwerp: [WD Community] [WD Legacy Products/WD TV Live & Live Plus] Network share after Windows 10 Creators update fails

https://community.wd.com/u/g_rayn G_Rayn
June 5

Hello,

Did you verify if the network discovery settings are turned on by going to “Control Panel\Network and Internet\Network and Sharing Center\Advanced sharing settings”?

After years of trouble free use, my WDTV LIVE, no longer sees the network shares. The sharing has been turned on and the modem sees the WDTV LIVE. It appears to be hidden by setup.

Only after the windows 10 creators update! For some reason the system will not let me go back, or I would.

Is there a fix for the Creator update problem?
Bob

2 Likes

This relatively obscure fix worked for me after long hours of research. Has to to with the elected “master browser” for your network workgroup in Windows. WDTV being legacy depends on this support for shares and has trouble if it is set to anything but your router (due in part to other machines being less dependably available on network). Here’s how to remedy:

Explanation of master browser function and invaluable “lanscan” tool to determine current master browser:

From the above linked page download the lanscan zipped .exe (green “Download” link about 1/3 down the page), put the .exe in your windows folder and run the command “lanscan” from an admin command line window. This will list all the participants in your workgroup. If you do not see your router listed as “MASTER” you need to change settings in the Windows registry of the machine(s) listed as master browser. Here’s how:
https://pattersonsupport.custhelp.com/app/answers/detail/a_id/8124/~/disable-the-master-browser

FYI Windows 10 deprecated the master browser functionality for a time and then reinstated it. Check your the version of any Win 10 boxes you’re operating on to make sure that have a version that includes master browser functionality:
https://social.technet.microsoft.com/Forums/en-US/3101aeef-115f-4b6e-94c1-c3d0f575b116/master-browser-restored-to-windows-10?forum=win10itpronetworking

Another WD community thread discussing this material: