Network setup for Netflix?

I’m waiting on a response from WD support on this but thought I could query the user forum as well.  I recently bought a Live Plus with 1.06.42_B installed.  Before rolling it back to my favourite load, I tried a few things; the Netflix app in particular as that was the main reason for buying this unit.  I already have three devices on the LAN side of my in-house Network server (DHCP, router/firewall, print and storage server, etc.) that regularly access Netflix, so adding the Live Plus to Netflix should be a breeze, or so I thought.

Performing the system and license key resets as recommended in several fairly old threads in this forum, I connected the Plus to my LAN. Launching the Netflix app, it returned the screen message "We’re unable to connect you to Netflix. Please try again or visit www.netflix.com/tvhelp for guidance.", along with “try again” and “exit” buttons.  Try again did not yield anything different and I was forced to exit.  Visiting the netflix website was practically useless as they have almost no information or archived FAQs regarding WD TV Plus players.  I rolled back the load to 1.06.16_B, reset everything again, but exactly the same behaviour was observed. 

I decided to try one of the generic debug suggestions on the Netflix troubleshooting webpage, and connected the player directly to an Eth port on the DSL modem.  When I did this, the Netflix app presented the big red loading-bars splash screen, followed by the login/try free splash screen; clearly it was now connecting.  Moving the player back to the LAN side, the previous behaviour returned.  Clearly, the Netflix app doesn’t like something in my network, something not affecting the three other Netflix capable devices that are on the same LAN and subject to the same firewall rules.   I rolled the firmware further back to 1.05.04_B, but again got the same results.  I tried playing with auto and fixed IP address, to no avail.  I might add that all of the other Plus’s Network apps I typically use (AccuWeather, Flingo, Youtube) operate perfectly, the latter two able to stream videos without any problem.

I know a lot of you have Live Plus units and I can assume you have Netflix operational.  Those of you that use a router/firewall, have  you had to do anything special to the firewall settings beyond the publicly revealed usage of ports 80 and 443 for TCP packets by Netflix?   I can’t find any really specific details in this WD forum  and I’d like to be able to have my player on the LAN so I can share attached storage amongst the players and PCs on my network (this works very nicely with my two Live units). My cheap network blu-ray player supports Netflix and connected right out of the box with no trouble through the same LAN.   Same is true for my son’s XBOX360 and Macbook Pro.

Hi, try entering the DNS number manually on your WDTV. Check page 24 of the manual for more information. 

http://www.wdc.com/wdproducts/library/UM/ENG/4779-705043.pdf#page=28

Hi Ichigo

I notice you are WD staff;  is this the official support contact I’ve been waiting for or should I still expect an email exchange?   As far as DNS goes, been there, done that.  In fact, I had a previous post exactly regarding DNS, per this link;

http://community.wd.com/t5/WD-TV-Live-Live-Plus/Check-your-DNS-server-if-WDTV-apps-are-not-connecting-to-web/m-p/583166#M32335

 

Alas, all my efforts to try to solve this issue, including playing with DNS settings, will not permit the Netflix app to connect, even though three other (non-WD) devices on the same LAN readily do.  I really need to know what the Live Plus is looking for that’s different from the other devices.  Since my Flingo and youttube apps are working great, I doubt this is a DNS issue; the Flingo app in particular is sensitive to a daft DNS, so I would think it would also satisfy the Netflix app.  I know its not anything at the ISP or the Live Plus unit itself since Netflix connects up when the Plus is plugged straight into the Eth ports on the DSL Modem.  I had suspected the firewall in my in-house server, but if that were the case, the other Netflix devices would not be able to connect either.

Have you exceded the maximum nuber of netflix devicesassociated with your account?  I think it is 6.

The Netflix FAQs do state that you can have up to six unique devices associated with your Netflix account.  Curiously, I currently have 8 devices associated with my account, and all will stream from Netflix just fine.

They’ve just introduced a couple of new plans that specify how many devices can stream AT THE SAME TIME.  Now you can get plans that allow streaming on one, two, or four “screens” at the same time.

@ BM and CJ

I had some suspicions about that too but the fact that it gets to the login screen when connected straight to the DSL modem seems to discount that possibility.  Connected to the LAN side of my network, the Plus is not even getting to the login page where, presumably,  Netflix service would message back that my device count is exceeded, if that indeed were the case.

I believe this is revealing a difference between the way the Live Plus communicates with Netflix vesus many other devices that appear to work straight away.   Anything I can find on the www about this says that Netflix only needs TCP packet service to ports 80 and 443, which is evidently sufficient for the three other devices I use.  Regretfully, the aging network server/router I’m using doesn’t provide a logging facility for the firewall function, otherwise I think I’d be able to spot the trouble fairly readily.   I’ve thought about loading up and (learning first) using WireShark, but was hoping this could be solved by WD as, interesting a challenge as it is, my time to play with this stuff is limited. 

My suggestion would be to clear your devices on netflix and re-add them starting with the WDTV.

Hi again RPH_16by9,

This is not support, please allow more time to receive it from the correct channel. 

So I got the support call.

The good news first.   As a customer who bought a used device that was well past warranty, I certainly can’t complain about WD’s support effort.  The tech I spoke with was courteous and respectful, stayed on the line with me for almost 1hr, going over things and consulting with the WD design team.  Kudos for really trying to help, I appreciate it.

The bad news:  problem still isn’t solved.  The most likely suspect is DNS resolution timeout, and the WD designers were not able to inform me how long the timeout is as the code is licensed from Netflix and they don’t have access to the source.  The reason DNS timeout is suspected is based on the following deductions:

  1. If it were the firewall in my system network server, the other Netflix devices on the LAN would also be affected as the Netflix app on the Plus uses the same link address and ports/protocol.

  2. The Plus connects and streams from Netflix just fine when connected straight to an Ethernet port on my DSL Router so its not anything in the Plus hardware.  Connected on the LAN side of my network server, the “cannot connect…” error message comes up every time.  All the other internet apps on the Plus work fine so its not due to lack of connection.

  3. My system server runs a local DNS server and performs a search before punting a query out to the internet.  Although a DNS translation request should clear through its local list fairly quickly, my guess is it that it adds just enough delay, summed with the external (internet) DNS server delay, to trip the DNS timeout of the Neflix app.

Why my other (non-WD) devices run Netflix fine from the LAN side could simply be explained by a difference in DNS timeout default.  This is the best theory so far and I have to figure out how to bypass my server’s internal DNS lookup without breaking anything else.  For now, until I find how to fix this, I’ll just string another ethernet cable over from my DSL router and just switch the connection to the Plus when I want to watch Netflix.  I’d leave it permanently connected but I want to be able to play shared media files from other devices on the LAN.