Network Sees MyBook Live as DLink Dir-601

I’m back again with this bugaboo of a drive.

Have been trying to get internet access to this drive for quite some time and have decided these past few days to really try and tackle it. 

I have upgraded and downgraded the firmware and finally did get the WD Discovery to work.  But it was still showing the wrong network.  So I assigned a static IP and then it showed in my router as well as in my network, but still not internet access.

Then all of the sudden, none of my network pcs had internet connectivity and my network showed as ‘unidentified network with no internet access.’  I thought perhaps my ISP was having a problem and called them and they said there was a strong signal to my modem.  They reset my modem for me and tried to reset my router but had no access to it (I bought the router from them so they do have access to them normally).  I reset the router and rebooted my pc and re-established internet connection in my network.

Now when I checked under windows ‘network conntions’ it shows all the windows boxes, my router and an additional DLink Dir-601!

That has to be why this drive has not been able to connect to the internet.  During the summer I was subletting and the router where I sublet was a DLink Dir-601 (that I had to set up for them).  Somehow, those settings seem to have gotten hard-coded into my Live.

So I performed a ‘factoryReset.sh noreformat’ command and then rebooted the Live.  When I check my network connections, that’s when I see the router that isn’t on my network AT ALL any longer.

Does someone know of a file that I can change or delete that will stop this from happening?  Or am I forced to do a total factory reset and wipe the whole drive?  Or should I just return this drive?  I bought the thing in March and I only use it as a nas, nothing else.

I can still see the files but not access them in the way I need to, which would be via a mapped network drive.  I can only access them through the WD Discovery via ‘Browse’ and that is not really too good of an option.

Thanks for any helpful ideas.

Cheers from a frigid Montreal.

I’m confused… there’s NOTHING in the MBL config that’s specific to any brand of router. The only config item that’s router specific at all is the Default Gateway setting.

ramses514 wrote:> Now when I checked under windows ‘network conntions’ it shows all the windows boxes, my router and an additional DLink Dir-601!

 

That has to be why this drive has not been able to connect to the internet.

That’s in Windows, not in the MBL.   And Windows settings have absolutely no bearing on the MBL’s capability to access the internet.

Your subject line reads “Network sees MyBook Live…”  Again, I don’t know what that means.   What “network” sees what?  Where are you looking that leads you to think that?

Posting screenshots would be helpful.

Hi TonyPh12345,

OK, perhaps there is something within windows that is remembering the old network from the summer, however I did go through my control panel and remove every remembered network when I moved to my new place.

But that still wouldn’t explain why my ROUTER doesn’t see the Live, nor why it is assigning itself an IP way outside of my network…it looks to be like it’s on a separate subnetwork.  But now I can’t seem to actually get back into the Live through Putty or WinSCP either.  I was hoping the factory reset would have fixed all of that.

It is windows explorer where the Live is now listed as a Dir-601, as I don’t own one, but that’s AFTER doing a factory restore.  Unitil then it showed MyBookLive.

After posting this I went into my control panel in windows and there were some saved networks from the spring (maybe I had done a system restore at some point?) so I deleted them again.  Then if I refresh my explorer in windows it still shows up as either the Dir-601 or do you think it is the ‘Intnetnet Gateway Device’ that is listed?

WD capture 2.JPG

I deleted all my wireless networks from the control panel and then refreshed my explorer in windows.  Here’s a screenshot:  The MBL is plugged into the router but doesn’t show up at all.

And here is what shows in WD Discovery:

Discovery tool actually DID let me map a network drive just now.  :dizzy_face:  But I cannot configure the MBL403 error 'FORBIDDEN - You don’t have permission to access /UI on this server.

That address, 169.254.xxx.xxx is an APIPA address. The WD assigned itself that address because your router didn’t provide one via DHCP.

Well, I put the MBL mac address in the router and reserved an ip for it.  Any suggestions as to what I might be able to do now? 

TIA

You’ve said that you got your router from your service provider and that they are not able to access it, that you no longer see it on your network, that it’s not providing DHCP addresses, etc…

Given all the issues your router is having, I would guess that your router is the source of the issues.

1 Like

@TonPh12345-Thanks for all of your input.  I’ll mess about with the router settings.  Actually, my network does see the router as shown in the previous posts.  It’s the ‘internet gateway’ that is listed, it also shows as DIR-825.  Hopefully I will get to the bottom of this.  Learning something new every day.  :neutral_face:

@TonyPh12345

Thank you SO MUCH for pointing me in the right direction.  The problem was solved by simply resetting the modem to factory settings and starting over.  Really, the only router setting that looks different now is ‘NETBIOS ANNOUNCEMENT’ which is now unticked.

So in the end, it was ‘operator error’ and I accept with humility that I had been the one all along that was wrong.  But, on the positive side, I learned a bit about networking along the way…not to mention a whole heck of a lot about unix/linux that had always made me think it was way too mystifying for me to ever grasp any of it.  This is one of those times when being an ‘old goat’ with some MS DOS experience has actually helped me out in the long run.  And since I do enjoy learning new things… I’ll take this whole experience as a good learning one.

I appreciate your pointing me in the right direction.

My network in windows explorer now:

WD Discovery worked and got me into Dashboard:  Do I dare update the firmware?

FW update.JPG