Network password issue

Hi all,

I have created a user and a private share, when I now try and access this folder Windows Explorer to put some files in it, I get a “Enter Network Password” message come up in a box with user name and password entry boxes. I have tried entering the users username and password but still comes back with the same box

This is a home network with no startup logons or passwords on any of my machines, can anyone point me in the right direction. (The only network password I have is on the router, and that username and password didnt do anything)

Using Windows 7 in case that helps



I hate to ask this - but is there any chance you have made a typo - or have inverted some characters.  I believe both the userid and the password are case-sensitive.

You could always try changing the password for the user on the MBL via the UI.


I wish it was that easy :frowning: I have retyped the password so many times, but the only thing that seems to work is if I check the “no password option” but only on all users, including admin, then it seems to work fine, but not very protected.

:slight_smile: and never hate to ask, im the one needing the help, happy to look at all possibilities, including me being stupid!


I just tried this on my Windows 7 box after reading your post.  I created a user Xyz and password Abc - and had it create a private share with the same name as the user “Xyz”.

When I connect to the share on Windows 7 - it pops up a user/password dialog.  I am able to enter the user name in “case insensitive”  (XYZ, Xyz, xyZ, etc) will all work.  The password is case sensitive.  If I enter anything other than “Abc” for the password - the dialog keeps popping up.

Did you use any strange characters in the password - just a thought?  Does it make any difference if you change the passowrd.

I believe your windows box is “passwordless” - correct?  I don’t think this should cause an issue - but in general practice it is best to have a userid and password required for every PC and laptop in your house - even if it is the same user and password for all - but the “no password at all” is not safe - for a variety of reasons.


Also - please check your firmware version and make sure you are on 02.10.09-124.  If you are on an earlier version of the firmware - you need to upgrade to the latest.  The upgrade will fix a lot of problems with the MBL.

Thanks Sbeattie2,

I have the latest firmware, first thing I did, I have been trying for a few hours now and still have the same problem, going to reset the flipping thing and start from scratch in case its something I did wrong in setup.


Okay - I am curious to know what you find out.

Well, I reset the unit, I am now getting a faster UI which is helpful, but still getting issues with not being able to get into folders, at least not on my computer, on my wifes she seems to have access to everything without it asking for any passwords at all, but mine is still keeping me locked out.