Network password in Windows 7?

Has anyone gotten this thing to work under Windows 7?  I’m assuming the answer has to be yes, but it’s really got me stumped.  After a reset to factory defaults, I can see and access the device.  But as soon as I change the device name and workgroup, it begins popping up a “windows security” window, which asks me for a network user name and password.  The user name and password used to login to the computer doesn’t work, and I’ve got no other network passwords set up.  I’ve wasted a lot of time on this thing today, and it’s going back to the store tomorrow if I can’t get a little bit better clue.

There is no default username and password for the MBL.  Have you tried to access it from other computers? Make sure that the workgroup is the same as your computer.

Yes, I have it working with multiple Win7 computers.

Do you have any other network devices that are “mapped” to your system? I have had problems with mapping conflicts. Windows using another mapped drives user/pass to access the wrong one.

Also, you said you changed the Workgroup. Are you using a private workgroup? I have never tried messing with the WORKGROUP setting.

Could you set a password on the device?

  • Go to the MBL web page and in the upper right corner click “secure your device” (or something like that). This will prompt you to set a password

  • Try accessing the device through Windows again

  • When it gives you the Authentication pop-up choose the option of using a different user.

User: [\yourdevicename\admin](file://yourdevicename/admin)(e.g. [\mybooklive\admin)](file://%5C%5Cmybooklive%5Cadmin)) 

Password: *whatever your set*

**This will tell Windows to use a user account on Mybooklive instead of the Windows account you are logged into

The results will help narrow down the problem.