Network negotiation fails

I have a WD My Cloud 2TB connected with an Asus DSL-n55U and the link drop every n seconds as if cannot negotiate the proper network speed (1 Gb). Connected with a powerline (100Mb) works fine. Can I force the negotiation speed?

@ Darkolo,

  1. How far is your WD My Cloud away ? 

  2. Use Cable that is delivered with it. Check the cable. Use or try another one.

  3. Use Cat 5e.

  4. No forcing, it should do this automatically. All lights should be green for 1 Gbps.

  5. Get a hub, switch, unmanaged switch and connect to the Asus DSL-n55U, put the WD My Cloud on there, put or assign static IP address in Router for My Cloud, reboot the My Cloud, let it settle. Check again.

Sorry, had to change nick for error during registration

  1. the WD is near the asus router

2-3) I changed 5 cables cat 6

4)the light stay green for 10 secs then they turn off and the connection in reset

  1. WIth a powerline the WD negotiate 100 Mbit full duplex

I’m able to enter in ssh to the WD and if I set 100 Mbit full duplex using ethtool it works.

At the office with Cisco switch the speed is 1000 Mbit full duplex.

I’ve reset the Asus also. I’ll try with a mini switch connected to the Asus router or I’ll buy another router

Thanx, but too late, I bought a Tp-Link W8980 and now it works fine.

Same here. Would you mind telling us how you can limit connection speed with ethtool step by step?

Try with this:

ethtool -s eth0 speed 100 duplex full