Network mode switching automaticly to DHCP

Hi WD Com,

actually im having kind of a strange issue with my MyCloud. I try to configure a static ip on the MyCloud. After filling the input mask and saving it, the url in the browers automaticly changes to the IP adress i just configured. So far so good.

At this point I dont get a connection, because I have to change the settings on the connected device first. (the actuall connected device is also set to DHCP) I just want to underline this aint the problem.

After several seconds the MyCloud CAN be reached again over its hostname / old dhcp adress. When i go back to network settings the network mode is again set to DHCP.

My question: Is this a kind of build in luser protection? Does the MyCloud automaticly set the network mode back to DHCP because the Client doesnt immediatly send a request to the new configured ip adress? How can I fix this Issue. I just want to have the network mode change, no matter if the LAN connection is working or not.

Thanks for your responses.

Greetings
Oompalumpa

Are you saying that after following the steps below, see image, that it changes back?

cat0w
USA

Yes, exactly. The network mode switches back to DHCP immediately.

Try this link and see if it helps.

1 Like

Hi Catow, thanks for your time. The Problem ain’t, that I i don’t know what I’m doing. (Hope this doesn’t sound rude. Englisch is not my native language)

It just seems like the MyCloud isn’t able to save the modifications I just made. Reffering to the link you posted: After fifth point in the instruction a mask with several configurations pops up. (such as IP, Netmask, Gateway etc.) When i click “Save” (after filling the mask correctly :wink: ) the UI starts to load, but after several seconds nothing changes. On entering the dashboard again (either with hostname or the IP from the old DHCP lease) and moving to the network settings, the network mode is set to DHCP again. It just seems like the MyCloud fails to save the settings properly.

Edit: Using latest Firmware WDMyCloud v04.04.02-105 : Core F/W

Sorry I can’t help, I have mine set on DHCP but reserved the address in my router so it stays the same.

You may want to click on Contact WD at the bottom right of the page and call or create a Support Case.