Network link down - NAS becomes inaccessible from the internet until reboot

#1

when i restart my router the NAS becomes inaccessible from the internet until it’s rebooted

iOS WD My Cloud app - Authentication Revoked
#2

Hi dcarbonaro,

You can try a 4-second reset which will switch your device to DHCP if it was set with a static IP address and reset the Admin Password (No password by default). Also it will not affect the data on the drives. You can refer below article to know more about 4 second reset of My Cloud EX2.

https://support-en.wd.com/app/answers/detail/a_id/7507

#3

Can I not just change the IP assignment to DHCP?

#4

This problem happens because when router reboots it supplies a new IP address for My Cloud Access /Cloud Service remote access port forwarding and rebooting NAS refreshes the IP address Always reboot NAS after router reboot, OR, A quicker way is to turn Cloud Service off and back on again. Very simple fix I have written about many times here.

https://www.google.com/search?q=mike27oct+cloud+access+port+forward&rlz=1C1CHBD_enUS759US759&oq=mike27oct+cloud+access+port+forward&aqs=chrome..69i57j33.150279j1j7&sourceid=chrome&ie=UTF-8

#5

My solution is correct one not the first one.

#6

WD SHOULD FIX THIS PROBLEM , because if router is unintentionally rebooted (e.g. power failure) remote access is hosed until reboot of NAS.

#7

I agree there should be a fix from WD

#8

I hope you saw more than my final comment and I solved your issue. If so, please mark the post as Solved. Thanks.

#9

The workaround is fine. I was after a permanent fix

#10

Yes, aren’t we all looking for “a permanent fix” to many of life’s glitches! This is not a workaround,-- it is a FIX – just not a permanent one! Welcome to the World of My Cloud. There are more of these glitches in your future.

#11

Well i dont think i will be enjoying those glitches… probably switching to something else

#12

To trade for another set of glitches from another brand of NAS, eh? No company makes perfect products. WD devices are fine. My NAS is working fine for over six years…

#14

Tried bot static and dynamic IP. Same issue