Network connection problems when uploading large files to USB-connected drive


#1

Hi,

I have a white LED MBWE 1TB and newest firmware upgrade, and attached to it via USB is a MyBook Essential 1TB.

I use this from several Windows machines (XP, Win7) over SMB (windows share usb1-1share1 on mybookworld).

My problem is: whenever I try to upload larger files (> 1 GB) to the USB drive it doesn’t work – after some uploading I always get the message that the network resource can’t be found, and it leaves me with a partial file on the USB drive.

I tried uploads from different machines using Win XP and Win 7, and I tried FAT32 (formatted over the MBWE Web interface) and NTFS (formatted by connecting the USB drive directly to a windows machine) on the but nothing helped.

I never have this problem when uploading to the MBWE internal drive, only with the USB connected drive.

This essentially means I can’t use the USB drive … :frowning:

I don’t know what to do anymore, any ideas anyone?


#2

Hi,

i still have the same problem, moving files via the copy manager from mbwe to the usb connected WD Essential is working without any problems. Only the direct copy from a windows XP or Windows 7 maschine to the usb via the mbwe is not working.

Do you found a solution???

Thanks in advance,

regards

Herbert


#3

I have the same issue. I already contacted WDC support and they are trying to convince me that it is a Microsoft issue. It does not work on Vista nor Win 7.

Here is the latest replies:  "The drive is a My Book World NAS, a network drive and not a USB Mass Storage device. It is therefore not possible to copy anything to it using the USB port for obvious reasons.

The USB connection is meant to be used as a way to connect a USB mass storage device TO the drive in order to be able to make backups, not as a communication port to a computer."

“Please be aware, that this issue is not related to the drive but to the operating system as the drive is not implied in any type of calculations. I would suggest to contact Microsoft Support where you will be able to get the necessary support.”

None of it explains the issue.

I will update the thread if I get a response.

Nobody else has the same problem???


#4

Hi,

same issue here. When i copy large files via the mybook world directly to a 2TB attached WD Elements on the USB port of the MBW i always get this error. When i copy the same large files directly to the MBW it’s working.

I also contacted the support and they told me i should call Microsoft. ;-((( The support is really bad, and i thing i will buy next time when i buy a NAS no WD product.

regards

Herbert


#5

I’ve been having the same problem and it seems that nobody can point out the problem. It is really frustrating because I have a mybook essential connected to the mybookworld and simply said it’s a piece of ■■■■ for the moment. I can copy files but not larger than 4 gigs. Maybe splitting the files with winrar could be a sollution for the moment …

I don’t understand that WD doesn’t know about the problem. You schould think that at least they tested it. I contacted support but they knew as much as I did, nothing !

They advised me to RMA the drive, but that’s no sollution. The problem wouldn’t be solved.


#6

This is a shot in the dark  …

My understanding is that you are copying from a Windows computer to the NAS or USB drive attached to the NAS.  In Windows under manage network connections, go to the properties of your lan card, click configure and then advanced.  Change “Large Send Offload” to disabled.  I’m using Vista so that’s what my system says.  I have to do this to get robocopy to work on large files on my Realtek RTL8168B/8111B Family PCI-E GBE NIC.


#7

I am having the same issue and this worked for me so far but needs more testing.  I was able to copy 12gb w/o a lock-up and another 12gb about 8 hrs after that.  The real test for me is to copy 12gb and another 12gb within a shorter time window.  I’ll try to complete this later tonight.

UPDATE:  I was able to copy 61.3gb of data in a 90 minute window w/o one single lock-up.  I should also state that I am using a WBEII WL connected to the network so this doesn’t appear to be the same setup as described in the thread.  My apologies but I hope this information fixes your issue too.

Thanks for the advice on the NIC configuration.  Much appreciated.


#8

I am also experiencing this problem.

I have two WD MyBook World Edition 2TB drives, white with white LED.  To each, I have connected a 1TB USB drive which is a WD My Passport Essential SE.  I received all 4 drives three weeks ago, so the MyBook firmware is 1.01.18.

I am using both MyBook drives with all of my configuration work through the web interface that comes standard with the drives (Network Storage Manager).  My configurations are to turn off everything (as much as I can) except the CIFS.  With the CIFS service, I have created a folder share that goes to the 2TB hard disk inside the MyBook, and I am also using the default share name that appears when I plug in the USB drives:  usb1-1share1.  I have no quotes, no permissions, everything is open and public to the local network for these folder shares.

I am performing copies in the early AM via Robocopy.  I have also done a lot of hand copying to test using Windows Explorer.  I am running Windows Server 2008.  I can always navigate in Windows explorer to see the MyBook drives and see the attached USB share.  My copy jobs range from 30GB to 160GB.  Everything works well when copying to the folder share inside the MyBook.

When copying to usb1-1share1, however, either by hand or via Robocopy, the network share name (usb1-1share1) eventually is reported to be unavailable.  Thus, a 100GB Robocopy job might copy 50GB or even 70GB, but then error out on the rest of the files.  But, in the case of an overnight Robocopy job, when I go to look at the situation a few hours later, in Windows Explorer I can navigate to the USB share.  During the time when the network share name was unavailable, the CIFS logs in the Network Storage Manager show that the USB service was connecting and closing.

I should add that the MyBook drives are connected directly to 1GB ports on a Dell GB switch, which then connects to the server running Windows Server 2008.  Some of the commentary in this tread discussed adjustments to the NIC on the computer, but that doesn’t apply here because the copy jobs start and work for a while.

To me, this has to be a problem with the firmware in the MyBook that manages the connectivity to the USB drive.  I have a few other things to try in the mode of alternative component debugging, but I hope WD is watching this thread for attention in a future firmware upgrade.


#9

This is definitely a BUG and a problem of the firmware. When you look more closer in to this problem, you will find that core of MBWE II is from 2008. WD are interesting on the customers only when they use the credit card in Internet shops and then it will end from them. Look on this forum and hundreds of complains from customers! Do you know more problematic device than this?  They are aware abut this problems and user solutions more than 9 months, and they are doing nothing!!! It was a big mistake to buy WD product, look on other companies, I have jukebox from TviX and they have new firmware with BUGs fix and new functionalities every 2 months!!! Unbelievable the difference.

WD should start to think about the future, because in this way they will lose more and more customers!