Netgear R7000, Internet Traffic Meter causing WD Live Hub to go berzerk

I have used WD’s line of media players for years.  I have had or have them all.  I have had pretty good luck with them, I have only had to return one to the store because it quit working and I have a WD LIve Plus that bit the dust a few years back.  So I am no stranger to how they work.  I have not “Modded or Hacked” any of my units, I use them just as they came from WD with only the lateset WD Firmware Updates.

My current network set up is as follows:

From the broadband modem I have a CAT6 cable that goes to the internet port on my

Netgear R7000 Nighthawk Wireless Router, then I have a CAT6 cable to my

Netgear 10/100 (non-gigabit) 16 port network switch, I have all CAT6 cables connecting the following to the network switch:

Port 1 incoming from wireless router

Port 2 Media Center PC running Windows 7 64 bit

Port 3 WD Live Hub

Port 4 Dell Inspiron Laptop running Windows 7 64 bit

Port 5 HP J8650 All In One Print Center

Port 6 Roku Media Player (it replaced the WD TV Plus that crashed)

No other ports are being used.

We also have 2 Galaxy S3 cell phones and a off brand tablet that connect wirelessly to the router.

Now for the problem discription…

I upgraded my wireless router a month ago to the Netgear R7000 from a Cisco wireless router (I don’t remember the model, but it’s irrelevant). At first everything worked just fine, but as I began to explore the new features of my new router and started turning on different features, my WD Live Hub started acting strange.  First it wouldn’t play any files from its internal 1 TB storage.  Then it started rebooting on its own and it wouldn’t stop, it just kept rebooting over and over again in a continuous loop.  I tried restarting it, by unplugging it.  That worked a few times, the files would play but stop after a few minutes.  When the files would stop, sometimes it would kick me all the way back to the main menu screen, other times it would just display a black screen until I pressed the back button on the remote.  At some point, it dawned on me that all this mish-mosh started when I was tweaking the router settings, so I started undoing all the things I had done.  When I turned off the Internet Traffic Meter and cleared the settings and applied the blank settings to the router that corrected the problem.  It seems that if you turn on the Internet Traffic Meter it causes a conflict somehow.  At first I thought it was because I had reached my monthly data quota I had set in the router and the router sent a splash screen to anything accessing the Internet stating that the monthly data quota had been exceeded.  So I turned that off but left the Internet Traffic Meter on, it still caused problems.  So I just turned that feature off entirely and my WD Live Hub seems to be working fine now.

I spent several days looking for a solution to this problem on the Internet and tried everything short of resetting to the factory default settings, I even backed up the WD Live Hub and erased 200 gig of media thinking it was a swap memory or a hard disk full problem.  That is the reason I post this here, just in case someone has the same problem and can’t find a solution.  I do sincerely hope this is a help someone in the future.


That’s interesting.

Any ideas what the Internet Traffic Meter is actually doing that might cause this?

That’s interesting. After upgrading to a netgear R7000 and turning on network tracking (which was the reason I bought it to begin with), my oppo105 (which is part media server) also started going nuts. I’m now testing to see if turning off network tracking fixes that problem. It also seemed to cause some other issues with the router. 

If the R7000 continues to give you problems you might try tomato or dd-wrt firmwares