Netflix - loading, hangs

I’ve seen several posts around the net, stripping the player of any hope of improvement to Netflix. Unfortunately, I have little hope to offer… I’ve spent hours trying to get it to simply start playback, trying all sorts of little nuggets of info I’ve come across. This includes two hard resets, with various attempts at coaxing some movie goodnes out of the **bleep** thing. Now, at last, it came past the “Loading”-screen, and started playing video. At the last attempt, audio was clearly present, but the video was hidden behind the “Loading”-screen, stuck as if glued to the screen. At the present time, I’m almost afraid to stop the episode… I really hope this part of the player gets a workover!! It clearly states on your website that this service is available. Please make it so!! A rare indulgence as this player and a Netflix-subscription is for me, the frustration and disappointment is huge.

Edit: By some miracle, the next one played!

Nice, I heard that netflix had an outage. 

Well, at this point it seems to be a roll of the dice wether it plays or  not. I watched two episodes, third failed. Went back to main screen, back in again, same thing. Turned it completely off(holding power-button, meaning I’ve got to dig the remote out of the drawer, won’t do that with my Harmony…) and fired it back up - worked. Had to run an errand, but dared not stop it, and left it on, thinking the screen saver would keep me covered - ain’t working in Netflix, it seems… The strange thing is, like you said with the outage, I can play perfectly and without failure on my computer, even my phone, so I’m having real trouble making sense of this. It’s like the unit doesn’t have the power or memory to get the job done. Sooo frustrating, the WAF is dropping by every attempt :wink:

Yep, get used to this behavior. The most recent annoyance with ours is, IF, you get to watch a movie/show, it will be the only one you get to watch. If you try and stop it and view another, your doomed. Only unplugging it will get it to respond again. If you try to let the new app ‘feature’ load the next episode, your doomed. Only unplugging is your only option again.
My best advice:

Yeah, I’ve seen that post, and it’s tragically comical. What makes it even more frustrating for me is that content from the connected 2TB drive works flawlessly, each and every time. There is clearly plenty of guts in the thing for playing high quality video, but the Netflix-app seem to be too much for it. I really don’t know what delivery system is used(silverlight in windows, no idea on mobile), but if my previous phone(HTC HD2 with Android ICS on it) could play this, how can they make such a mess of it on the WD TV? Now I end up with my laptop and a headset when ever I want to watch something. :confounded:

Same here. Yeah we’ve pretty much given up on it too. It should not be advertised with Netflix as an option, it’s not fair to people.

I’ve been thinking the same thing, it’s misleading! I do like the Spotify-app on it though - that does what it says on the box. Hulu I haven’t dared trying… Guess I’ll stick to downloads and the laptop while I keep nagging in here.

I’ve now tried 3 boxes. I have never had success with Netflix. This device should not be advertised as having working access to Netflix, it is thoroughly inaccurate.

I am experiencing the same thing, Netflix is constantly hanging and or loading/not connecting. Very unfortunante, we use netflix quite often and its a pain having to switch to another device to watch it. hope its being worked on and fixed in a future update. the Netflix app on the Xbox works flawlessly and this app looks to be the same as the boxee one which I’ve seen work flawlessly as well.

I’ve given up. If you wanna talk about WAF, the thing just ain’t worth it… It works perfectly on all my computers, my daughters iPad, my sons PS3, my Galaxy s2(stock rom) - I really have no understanding of how Netflix can allow WD to do such a botch job of implementing their service. Sure, Spotify have a lower demand in terms of just playing music, but the app works great. It’s horrible.

I haven’t had any hanging issues, but recently noticed an odd issue, even after backtracking the firmware.

Some titles (Star Trek: Enterprise, Star Trek [original series], **bleep** on Wheels) no longer go to X-High/HD. They only go to High/HD. ST and HoW are still 5.1 audio. ST:E is only 2.0, as before.  But, I tried “Louie” and “Casa de mi Padre” (Will Ferrell spoof), and they run X-High/HD fine.

Obligatory keep this thread going comment.

On another site, somebody said they connected a drive to their box, and Netflix started working. Odd.

Andyross wrote:

On another site, somebody said they connected a drive to their box, and Netflix started working. Odd.


That site wouldn’t still be in your history where you can post a link, could you?

Whoa.  Coinkidinks of all coinkidinks.  Here.

AVS is usually my next stop after this forum.  :)

Hey, Christian1…  try out out.   Let us know if it works.

Heheh… And I see your post right after it.  :)

I’m glad that worked for some, but I’ve had a hard drive connected to it since day one - or rather, two different ones. Same result. I sent an e-mail to WD, and got some about netflix having issues. BS because there were no issues at that time on my computers, the PS3, or even my phone for that matter. Nor has the “issue” gotten any better since. So, as far as I am concerned, the Netflix logo should never have been marketed with the unit. Besides, I didn’t buy this unit from Netflix, I bought it from WD. It’s their unit that fails completely to do what it says on the box. I’ve always held WD in high regards in my more than 20 years dealing and working with computers, and recomended their brand. Time to reconsider, perhaps.

Oh, boy … here we go again…

If you read that thread again, you’ll see that the guy says it’s working WITHOUT an HD now… that he had made a mistake initially.  (“user error”).

Let me start by clearing things up - I screwed up :smiley: In the beginning I had my harddrive connected to my Asus RT-N56U router, and streamed from that. At that time I didn’t use Netflix, so I do not know at the moment how that would work. But you are right, I didn’t catch that part when skimming through his post, my bad… I will test and report back :slight_smile:

I’m the guy who posted the HDD fix for netflix. There should have been a question mark after “user error”. Netflix wouldn’t work right, I attached a HDD than a thumb drive and it fixed the problem. I later took the thumbdrive out and it continued to work properly. So I would say if your having a problem give it a try it can’t hurt, worked for me.

I made no other changes.



There are some weird things with the WDTV. In order to the change the favorites screen, I had to connect a thumb drive, but even after disconnecting it, it kept hte changes. I wonder if, especially on a ‘new’ box, it needs some scratchpad space for the initial setup now. I never had any issues, but I’ve had mine for a year or so now.