Netflix issue - a real mind bender


#1

I have been slowly driving myself insane with this issue and I hope that someone has defeated it previously.

I have 2 x WDBGXT0000NBK that I have been using hassle free for many years now. All the streaming apps, including Netflix, have worked without a hitch.

Recently, in an effort to ahem maintain the maximum value of my Netflix subscription, I have set up a dedicated VPN router that is cascaded from my internet gateway/router. This has effectively created 2 wireless networks in my home, one accessing a local LAN and the other my VPN service. This it where it gets strange.

When connected to the local LAN, the WD TV units can access and play shows on Netflx (and start all other apps) without a problem. However, when connected to the VPN, all apps work EXCEPT Netflix. I initially through that it might have been an issue with the VPN connection, however, when I connect my PC to the VPN and navigate to Netflix, it logs me in and I can stream shows without a problem.

So the issue is obviously with the WD TV unit, but I can’t for the life of me figure it out. I have reset the location, adjusted the time, booted and rebooted until the cows come home but the end result is the same: the app starts and hangs for a while and I get a message saying it is unable to connect.

Has anyone come across this and/or has suggestions how to fix it?


#2

Hello,

I have not try this. Not sure what can be causing the issue.

Lets see if any of the users can share some information about it.


#3

A bit of an unorthodox setup to be sure. Maybe the WDTV only allows one Netflix stream at a time through it. Also, I believe I have no problem streaming Netflx (to Roku) and at the same time streaming to an iPad, say. Don’t do it much. Don’t even use the WDTV for Netflix use; it plays our videos and music, that’s all. That’s it. So, if you get a Roku you would have two devices to stream Netflix to TVs with. We have two Rokus on TVs. Netflix also has limits on the number of registered devices it allows for one account.

My suggestion is get a Roku, put it on the other TV, and do away with the VPN kludge. Maybe I don’t even understand what you really are trying to accomplish here. Are you (ahem), try to pick up something from another country by using the VPN? I think I read somewhere that Netflix doesn’t like this, and is blocking it now. Especially in the former Soviet block countries where folks in one country are trying to pick up Netflix from another. Is what you are wanting to do? Whatever, and good luck.


#4

Does anyone have a more useful suggestion / idea than “get a Roku”??? After all, this is a WD forum isn’t it?


#5

Did you even read my last paragraph that says Netflix is blocking VPN access; especially from those trying to skirt the Netflix system to do what it appears you are trying to do?

If you had googled for info you could have found this.


#6

And if you read my post, you would see that I could (and still can) access Netflix via my VPN on my PC. :expressionless:


#7

Each device that can access Netflix does it differently. a PC does it simply via the Netflix app installed. a WDTV does it with hardware, same goes for a Roku and Fire Stick, and casting to a Chromecast from a phone or tablet is different. That’s why I suggested try Roku or other hardware, Maybe the WDTV is not up to the challenge. Hardware methods like a WDTV actually have a chip that allows or disallows Netflix and prevents copying of the stream.


#8

I have the same issue, just installed an ASUS AC1900 and put OpenVPN on it. When activated Netflix on the WD fails, deactivate and it works. I have an android TV box with Netflix that works with no issues over the VPN as well as computer. Has anyone tried flashing the WDTV box to an older level of firmware?


#10

Netflix is one of the finest sources to watch movies and tv shows of various languages across the globe though it is paid. But GHD Sports APK is the one and only free app that provide live free sports streaming.