Netflix/Hulu problems after upgrade to 1.07.18

Hi guys, I have the WD TV Live Gen 3, I think it’s also called the WD TV LIVE Streaming. I updated to Fimware 1.07.18 when it became available. I updated it over the network from the device itself. It is connected to my TV using HDMI. Pretty much ever since the update, my netflix and Hulu playback are impossible. Basically the behavior is this:

In Netflix, I can browse around and see all the titles, look at all episodes, etc. HOwever when I try to play a video. it buffers it up and then goes to a black screen with occasional white flickering spots. If I hit stop, it will return to the episode/video selection screen and I can see that some progress has been made in the video, so I think it IS playing it.

In Hulu, it’s a crapshoot if Hulu will even start now, after I click on the icon, sometimes it will load fine and I can start a video, however the exact same thing happens as happens on netflix, black screen instead of video playback. Other times, Hulu never loads, just goes to the black screen.

I’ve no idea what is causing this, and I cannot find a way to rollback my firmware, or reflash the new firmware from USB. I have done a full system restore, no change. The device still plays videos across the network without issue. I searched the forums to see if anyone else had this issue and I was unable to find anything similar. Does anyone know of a methid to rollback the firmware on a Gen 3 WD TV LIVE?

Well I tried that, doesn’t give option for upgrade firmware with an older firmware on the usb stick. I’ve written WD about it as the article suggests. Does anyone recognize the behavior I mentioned? The black screen instead of video playback?

refrax wrote:

Well I tried that, doesn’t give option for upgrade firmware with an older firmware on the usb stick.

    • *You downloaded one of the files using the links on that page?

Yep, the one prior to 1.07.15, and I have it by itself on a FAT32 flash drive, no option for new firmware on the WD Live. I treid booting the device with the drive in, and also booting the drive with no USB storage attached, and then plugging my flash drive in after it was on.

Open the VER file in notepad, and paste it here .