Netboot Acronis/Parted Magic/ Windows from from MBL

I managed to get Netboot to work with MBL

MBL PXE

  1. Precondition:
    Generate a Public share with the name „Netboot“

dd-wrt Router>> Enable  DNSMasq  Option :“ dhcp-boot=pxelinux.0,zorro,192.168.1.2“
(You have to change 192.168.1.2 to IP address or your MBL)

2 . Install Feature Manager (needed to get access to ipkg)

Visit http://www.highlevelbits.fr/ and select My book Life >>Feature pack Manager and follow the necessary steps

  1. Install Optware:

Visit http://mybookworld.wikidot.com/optware and select My Book Live

Follow Instruction

  1. Install optware

Midnight Commander (For better navigation using putty)
 /opt/bin/ipkg install mc

Nano (Better then VI)
/opt/bin/ipkg install nano

Update packages for apt Get

apt-get update

Install TFTP Demon

apt-get install tftpd-hpa

(install without verification)

Check TFTP-HPA was installed

dpkg -l tftpd-hpa

 

5.       Config and start TFTPD

Edit config file tftpd-hpa to your own needs and move it to /etc/default/ using MC

Important:  RUN_DAEMON=“no” >>> important to start with INIT.D

Edit /etc/inetd.conf to your own needs and ensure that the “#” was removed in the front of the line

Example:

tftp           dgram   udp4     wait    root  /usr/sbin/in.tftpd /usr/sbin/in.tftpd -s /shares/NetBoot -m /shares/NetBoot/tftpa-hpa.remap -vvv

Init 6 to reboot mbl…  If everything is fine TFTP should allow booting via network

6.       Enable HTTP access for Netboot (Netboot2)

6.1   Softlink
Firmware Version 2.02 was the last one which allowed to download data by http from MBL without Access Restriction. We will use a Softlink to get this done

ln -s /shares/NetBoot/ /shares/NetBoot2

6.2   Setup Apache2

Use MC to navigate to edit  /etc/apache2/sites-available/wdnas
Insert the following lines BEFORE

Alias /NetBoot2/ “/shares/NetBoot2/”

       <Directory /NetBoot2/>

            Options -Indexes FollowSymLinks MultiViews

            AllowOverride None

            Order allow,deny

            allow from all

Save the file.

6.3   Restart Apache2
To get the changes active we need to restart Apache

/etc/init.d/apache2 restart

Now it should be possible to access the contains from share Netboot by using:
http://192.168.1.2/Netboot2/

Attached you will find a archive with the needed bootfiles (my config) and config files for TFTPD and Apache

http://ul.to/qufbxm3r

This procedure has worked for me… but i’m not responsible if your MBL somhow gets hurt

1 Like

In step 5 you say “Edit /etc/initd.conf”

Do you mean inetd.conf?

You are right… Sorry … it was a typo…

btw

If you want to boot Windows you will need the folders Boot,Kernel. Sometimes with capital first leter sometimes without. A Softlink (Boot >>boot,Kernel>>kernel) will help to get this done

Last but not least it could be that you need to change owner of the NetBoot folder (I changed it to “Nobody”

I was successful but had to go about it a little different

I have an Asus RT-N66U router

I had to install Asus-WRT Merlin to gain SSH access to my router

I edited /etc/dnsmasq.conf and addded

dhcp-boot=pxelinux.0,,192.168.1.6

192.168.1.6 would need to be replaced by YOUR MBL IP

I also took out the hostname “zorro”

Then I had to restart dnsmasq because rebooting the router writes back the default dnsmasq.conf

killall dnsmasq
dnsmasq -c 1500 --log-async -n

Note that this solution isn’t permanent as the router will restart dnsmasq on its own and overwrite the config file with its own but I could enable jffs to remedy this

Create a public folder in the dashboard called Netboot

 

Fire up PuTTY or Terminal

Install tftpd-hpa

apt-get updateapt-get install tftpd-hpa

When the blue screen comes up asking “TFPT ROOT DIRECTORY” I used /shares/Netboot

 Edit tftpd-hpa

nano /etc/default/tftpd-hpa

 The file needs to look like this

# /etc/default/tftpd-hpa

RUN_DAEMON="no"
TFTP_USERNAME="tftp"
TFTP_DIRECTORY="/shares/Netboot"
TFTP_ADDRESS="0.0.0.0:69"
TFTP_OPTIONS="-s -vvv -m /shares/Netboot/tftpa-hpa.remap"

Control and o

Hit enter

Control and x

Create /etc/inetd.conf

nano /etc/inetd.conf

Paste this (Right click)

netbios-ssn stream tcp nowait root /usr/sbin/tcpd /usr/sbin/smbd
tftp dgram udp4 wait root /usr/sbin/in.tftpd /usr/sbin/in.tftpd -s /shares/NetBoot -m /shares/NetBoot/tftpa-hpa.remap -vvv

Control and o

Hit enter

Control and x

I then copied the contents of your Share_Netboot folder to my Netboot share

I then created /Acronis/2013 in the Netboot share

I then plugged my Acronis TI Home 2013 thumbdrive in and copied dat2.dat and dat3.dat to Netboot/Acronis/2013

I then renamed

dat2.dat TO ramdisk.dat

dat3.dat TO kernel.dat

Restart tftpd-hpa

/etc/init.d/tftpd-hpa restart

Enabled PXE boot on my motherboard

Booted from PXE

Menu came up and I selected Acronis TI 2013 TFTP and it worked like a champ

Thanks for the write up -T_A_T-