Netbios over TCIP/IP must be enabled for network sharing


#1

This might be obvious to some, but I’ve spent the whole evening troubleshooting before finding the solution. Didn’t find this anywhere on the forum, so I thought I’d post it, hope it will help someone…

I couldn’t see my Windows 2003 Server computer on the WDTV Live… Sharing was enabled, I could access the server form my laptop (on the same network), and the WDTV could access my laptop if I enabled sharing. The server simply did not appear under “Network shares” on the WDTV.

I tried everything suggested in this forum, including switching the workgroup on the server to WORKGROUP, but nothing worked. Finally I found that “NetBIOS over TCIP/IP” was disabled in Win2K3 (it must have been the default setting, don’t ask me why!). Enabling this made the server visible to the WDTV, and everything worked!

(To enable NetBIOS over TCIP/IP, go to Properties of the network connection, then Properties, TCP/IP Properties, Advanced, WINS, Enable NetBIOS over TCIP/IP.)

Hope this can help someone!

/ Avalance


#2

There’s probably not a lot of folks running WIndows 2003 Server (you may be the only one :>), but at least those few who have issues have something else to try now.  Thanks for posting.


#3

Thanks a lot, after a lot of trial and error this finally made it!

My shares have randomly appeared with all firmware versions.

I am running a WHS and Netbios was not enabled as you point out - enabling it made my shares appear instantly.

Thanks again!

OO