Neighbours have access to mycloud via my wifi


I am new to having a cloud. We share our wifi with our neighbours. Which means they have the password to the wifi.
I noticed that any device can access mycloud and all the folders in mycloud if the device is connected to my wifi. I’ve searched but can’t find any answers to this ‘problem’. How can I be the only one accessing my cloud via the wifi we have at our house?

Can anyone please help me?

Give them “Guest” access to your wifi if your router allows it.

Some router’s have the ability to confine guests to a separate network than your main network. If so they would be unable to access your network and the WD My Cloud locally.

The My Clould has the capability of requiring a password to access Share folders with the exception of the Public Share folder. For each Share folder using the Dashboard set the Public Access for that Share to Off. this will force someone who tries to access the Share to enter a password. Once a Share’s Public Access is set to Off one can then configure the User permission level (Full Access, Read Access, No Access) for that Share. You can create multiple Users via the Dashboard each with their own private Share if you so choose.

If you haven’t done so already see the WD My Cloud User Manual ( for more information on how to create Users and set a Share to private. Or see the following WD Support document for making a Share private:

The one downside is the Public Share. WD has decided that this folder cannot be made private through the Dashboard (for what ever reason). As such anyone who can access your network can access the Public Share and any content stored there. Its why it is recommended NOT to store sensitive data in the Public share. There are various methods of disabling or deleting the Public Share folder. See the following link for some examples:

Further for media files it is also recommended not to store media files in the Public Share folders. See the following link for more information about media files, the Public Share folder and the Twonky media server contained within the My Cloud:

Your problem is sharing the Wifi and therefore your network with others. Enable “AP Isolation” oder however it is called on your access point to stop your cabled network being seen by Wifi clients.

Or use two wifi routes behind each other, the first router is connected to the Internet line and carries the “public” wifi, the other router is connected to the first router but has different IP address network. The second one is your personal router. So the second router blocks all “incoming” traffic from the first router by default and nobody can access your internal network.