Need to restart my "My Book Essential USB 3 & 2" drive every time I restart my Mac

This is really annoying, and if I sometimes forget then my timemachine will not back up for several days or weeks. I have 4 more disks connected to the mac and they are still there if I reboot my Mac. There is somehting wrong here. I have tried different ports and stuff like that, but nothing helps. Please look into this!!


This could be a problem with the drivers for it. 

This does not regularly happens on Mac, I’ve seen this more in Windows. You can also run First Aid on the drive and make sure the drive is not connected to a power surge or usb hub. 

As a last resort you can update the Firmware.

Tried both uppgrade of Firmware and yes the drive is conneted to the mac directly. If this is a driver problem then WD should look at this right away, or else they cannot state that it is working for the mac.

So what now? What first aid app are you talking about? I did run a diskutility check on it and I also reformattet, but problem is still there. SHould I send it back??

Do you have OS X 10.7 Lion? If so,  try downloading the latest  Turbo Drivers and see if that helps. 

BTW first aid is the test tool on disk utility. If none of the steps work, I’ll suggest for you to contact WD :