Need to restart EX2 after a few minutes of use to get remote access

Anyone know how to keep EX2 from going offline after about 20 minutes of use? It’ll still be accessible on local network but not remotely. And it seems only after use which seems to point to the drives resources maxing out.

I don’t think that this is a good solution but, try:

Settings > General > Energy Saver > Drive Sleep > OFF