Need thoughts & suggestions WD1600AAJB

Hi All;

Have a situation with a HDD (WD1600AAJB) which I’d like to correct at the very least to simply extract the data on a 1 year old HDD.  The chain of events ran as follows.

  1. Performed a Windows XP update.

  2. As happens on occassion with their updates, a file was corrupted (…VGA… something), and the PC would not reboot making it to the windows loading screen only.

  3. At that point I tried to do a windows repair with the CD, yet backed out of that to check on simply replacing the file before starting.

  4. When the PC tried to restart, I then get a “NTLDR” is missing error message.

  5. So then trying to repair once more with the CD, I receive the message that there is no HDD present.

  6. Finally, BIOS even stopped recognizing the HDD.

The HDD still spins up, makes no odd sounds, yet is not recognized as existing…At that point I’m beyond my skill set so speaking out of ignorance, yet I assume the boot sector or whatever is corrupted/damaged on the HDD.  Any ideas on how I can access the HDD if even just to recover some of the data if not repair the boot sector?

Thanks for any help,

K2

Other than disconnecting and reseating the IDE cable at both ends, or connecting the drive on its own to a different IDE port, I don’t know of any DIY solution.

As a last ditch effort, remove the PCB and use a soft white pencil eraser to clean any oxidisation off the 20-pin preamp connection pads on the PCB. Alternatively, try to shine up the pads with a cotton bud and metal polish such as Brasso. AIUI, current drive models have oxidisation issues as a consequence of materials changes mandated by RoHS.

Thanks for the suggestion, yet what I “think” may be wrong is the boot sector is corrupted…Fairly sure it’s not a cable/connection issue.

Thanks again,

K2

UPDATE: Using WD-DLT and setting the HDD as a slave, DLT recognized the HDD correctly yet then stated that the BIOS had it set to “off” and insisted I move the drive to the secondary as a master.  Going back to bios BEFORE moving the drive, it then saw it correctly in the list, saw it set to auto and continued on.

At that point DLT then saw it as some odd S/N (single letter and an odd symbol) again demanding I move it…Moved it, and it was unrecognized once more by both bios and DLT (and tried both ide ports), a few more boots later set up as a slave once again to the DVD it was recognized the first time, yet again not the second with the same demand to move it.

Ideas?