Need help with remote login in after demote a WD DX4000

Hi all,

First, I have to say that I am  a newbie of both WD DX4000 and Windows Server 2012 R2.

I installed Windows Server 2012 R2 on a WD DX4000 in a workgroup. I disabled the build aministrator account and created a new adminitrator account which was alse enabled for remote desktop control. I used it primarily as a file server for my workgroup and it had been working fine.

In order to solve connection issues with Mac clients, I installed the Windows Server Essential Experience yesterday. The installation promoted the DX4000 as a domain controller. After that the filesharing for the work group stopped working. I then did a forced removal of the domain controller (  , including creating a new administrator password as prompted. After removing the roles associated with Server Essential Experience and Active Directory, I was followed the prompt and reboot. After rebooting, I tried to connect to the DX4000 using remote desktop control and failed. No matter I used the various workgroup local administrator account(s), the domain account created during the installation of Server Essential Experience, or “machineName/Administrator” in combination with the new password created when demoting the domain controller, I am getting the message of “Your credentials did not work.”  

I have about 2TB of shared data are stored on the DX4000. Help and advice to re-gain my acess would be really appreciated. Thanks in advance.

Welcome to the Community.

A resident User called Gramps is quite familiar with the WD Sentinel DX4000. He may be able to assist.

LOL, yea, me here with no clue.

Just how did you get Server 2012 R2 on it anyway?  I looked at that article you linked and every other paragraph is a warning.  My guess would have been the administrator account you made when you disabled Administrator with the password you provided in the wizard.  Just for fun try whatever you think you typed as the password with caps lock on

You are in the US of A as in no funky great Britain keyboards may be involved?  And just to be sure, you are doing remote desktop to the correct box as in your DX4000.  I don’t suppose the LCD works if you loaded 2012R2 on it?

I think you may need to look at They have a demo.  As in take your drives and attach them with USB to get to your data on a working box. (That is if you have more than 2 hard drives which would be in RAID 5, two drives in a mirror you would not need any raid constructor software)

Hopefully your box is set to press the power button once to initiate a shutdown.  Bad mojo powering off these raids.

Does the box show up in network neighborhood on a local PC?  Do the shares show?


Thanks for the prompt reponses.

I installed Windows Server 2012 R2 following the guide posted at the following URL

With regard to the questions that you had asked:

  1. CapOn: no

  2. Inernational keyboard: no

  3. connect to correct box: yes-- works both using machine name and IP. Just cannot login

  4. LCD: not work

  5. Box show up in network: Yes;   shares shown: No. Click on the box, it prompts for login/passwod.

  6. RAID setup: 4 physical drives spanning as one single volume which is then partitioned into C (system) and C (data) partitions.

1 Like

I would suggest that you standup a VM or another box with a monitor and try to duplicate what you have done.  But I am not certain even if you did by seeing it would yield different results. And I suppose you would not be asking these questions if you had a backup of your data.

Obviously none of this is supported by WD or Micorsoft and I doubt the dudes at Wordpress blog would be any help. But you might try posting in the  Microsoft AD forum just to see.

Or you might try to google and see if there are any kinds of powershell commands or WMI stuff you could run against it and get a list of users.  You can’t do any of the password reset stuff on a headless box that I know of.

But I think your best bet is attaching the drives to another box to get your data and start over. 

When you were in workgroup mode did you create any users\passwords that might still get to the shares?

Here is another one someone here used to get data from the array, but it is $250

Free to try

Looked around some.  It looks like the username would be Administrator, but I do not know how that applies if you disabled it.  I know it should not matter, but try with a Big A in Administrator or the username you made administrator with the password created in the demotion.

Thanks for the suggestions. Did try both “a” and “A”-dministraor and neither work.

In fact, none of the workgroup accounts were able to access the shares after the box was promoted as a DC. That’s when I realized I did things wrong and tried to demote the box back to a workgroup server.  You are correct that I do not have a backup of the data. 

Could it be that the local accounts goe transferred to Active Directory during the DC promotion and got wiped out when the Active Directory was removed when I demoted the DC? Wonder if the following is possible?

(1) Connect drives to and boot from a PC 

(2) Create and boot the box from a PE with Windows Sever 2012 Installer + TightVNC. Use TightVNC viewer from a PC to reset the Administrator account.

(3) Do a repair install using the Windows Server2012 Essential ISO at

  1. Would only work if the MB had the intel RAID chipset.  We have always talked about trying it but I don’t know anyone who has. 

  2. and 3. I have no clue.  Would much rather have a test box first.

I would really suggest you use one of the proven methods to get your data back.  Again I have not personaly use either of the software paqckages I linked, but have heard from people who did.  It appears to not be damaging in any way and free to look.

The other idea is to simply post in the MS AD group something like.  I disabled the Admin Account and then removed AD and said it was the last DC and now I cannot login.  Anyone have any ideas? (Oh, it is a headless box)

Thanks very much for the suggestions. I had made a post in the MS Tech Forum and am working on recover the data. Will look for a MB with Intel RAID chip to test out later.

Let us know how it shakes out for you so we can learn something.


When you promoted the DX4000 to a domain controller, of course your workgroup sharing stopped working; you no longer had a workgroup, you had a domain, and your clients would need a domain account to login to see the share, unless the share permissions and the NTFS file permissions were set to Everyone - Full Control.

And the username is not case sensitive - only the password.

manoa wrote:. 

Could it be that the local accounts goe transferred to Active Directory during the DC promotion and got wiped out when the Active Directory was removed when I demoted the DC? Wonder if the following is possible?

If you activate the AD-Membership, all formerly local accounts will be deactiavted by the Domain controller policies. After downgrading back the system to workgroup, all AD-accounts will be deleted.

I read your link with the upgrade procedure - many thanks for sharing, it’s highly interesting!

The username is Administrator but the password is “P@ssword”. The location of the @ symbol is different due to language of the keyboard. Example German keyboard ALT-GR + Q, English keyboard SHIFT+2. Maybe this is the problem.

BTW: please post your experience with Windows Server 2012R2 Essentials on a DX4000 hardware! I am very interested in this topic :smiley: