Need help with remote access set up (domain)

Just received my DX4000.

I have a website that I own, it is provided by

The website we will call

I have a ssl certificate for, provided also by

I log into the server dashboard, go to “Server Settings” and select remote web access.

Router: WNR35003v2 (Netgear), evertying sets up fine

Domain name: I select Setup.  Getting started window, I hit next.

I want to use a domain name I already own, domain name

I get a screen “Update information on”.   If I use the button to go to and login, I am presented with a screen filled with information that has nothing to do with anything.

If I come back to set up and press next, I get a prompt to store my domain name info, user name and password I registered with

Username \ password credential entry.

I hit next, a few seconds later I am presented with a screen:  An error occured while setting up your domain name.  The domain name was not set up for your server, wait a few minutes and try the wizard again.


It appears the easy wizard is no longer the way to do this.

What did I do wrong, and what steps do I need to take?

I actually figured this puppy out.  You can’t use the wizard to do it.  It is outdated.

I had to downlad the certificate from godaddy (download IIS)

and then follow the instructions found in these forums for installing the certificate via mmc and the iis.

I had to also on the godaddy page for my domain, in in the DNS zone, make sure the was pointing to my static ip address.

yea, the wizard will purchase a cert and install it, but it is no good if you have already bought a cert cheaper than the wizard:)

SBS 2011 Essentials is the same as the DX 4000

Glad you got it working.

That link seem awful complicated.  I think it may be easier to just run the wizard and get a free domain from ms, then install the godaddy cert in IIS


I think GoDaddy has changed how they approach how they handle business and it has affected how the 2008 wizard works in this instance.

I think the solution I put in works.  For the longest time I had forward to

Now I can use as access to remote web access.  It doesn’t seem hard to change the DNS zone records to add and then cause to forward to in the future.  I can reissue my SSL on as needed.  Fairly straight forward process.  And maybe someday I’ll cause to forward to

Right now it is working fine.

Only issues now are:

1.  I get a server error that “REmote Web Access is enabled, but an Internet domain is not set up.  You must set up a domain name to remotely access the server.”   Like I said above, I have no issues accessing it.  I think there has to be a way to manually enter it via IIS.

2.  Remote Desktop access via Remote Web Access is not working.  I RD just fine when not using the Remote Web Access.  I’m wondering two things:  Is it because the computer in the office uses a non-standard port for RD?  I’ve turned off the targets computer firewall to see if it is a port issue, but that doesn’t work.  It may be a result of not having a domain as mentioned in 1 above.

when you surf to the server site what you type in the url must match what the cert says for remote desktop gateway to work

The internal PC;s must be working on 3389 as well.  There is no need to change the ports on the internal PC;s?

From afar rdgateway will use 443 encrypted, but then use 3389 internally

1 Like

I have the remote web access working

I can access the computers remotely through remote web access

Now, new issue:

At home on my Windows 8.1 machines I can access, login and everything works fine.

At home on my Surface Pro 2 machines I can access, login and get 404 error (same network, just wireless)

At work, through a local windows 7 pro machine, I can access, login and everything works fine.

At work, through my Surface Pro 2 machine, I can access, login and get 404 error (same network, just wireless).

I’ve made sure that my SP2 machine only has IE installed and is the default browser.  It is also fully updated through MS updates.  I’ve tried turning off it’s firewall to see if it changes anything.  Restarted the computer etc etc etc.

on ie11 you have to add the sites to trusted and use compaibility mode

From my bud Susan,

1 Like

And presto, it’s all working good!