Need help with new wdtv live media player and twonky server -avi files

Hi all, I bought Twonky server, I tried the trial and it all seemed to work fine, after I bought it it just started not to work.

I have my files on my time capsule, bridged to my imac, and have the path correctly set-up for sharing. Which then via ethernet cable streamed onto my WDTV media player. 

There’s a few problems I encountered, I have a friends old western digital media player and it works flawless when im trying to play a season I have of a tv show which are all in .avi files. The new WDTV media player I have wont play any file it just keeps ejecting itself. I cannot play the avi files on the actual streamer itself on the twonky settings on my mac but i can other files like mp4, could be that twonky cant stream it ? I tried to stream it wired and wirelessly both dont work. 

Could someone shed some light on how to fix this, need help desperatly.


Check if you have the latest firmware version, if that doesn’t work try pressing the reset button.