Need help. Trying to access an old WD400 EIDE from an old PC using USB cable

Greetings everyone!! Wondering if I can get some suggestions to my dilemma.

I had an old PC, probably running windows 2000 or NT. I upgraded to a new pc and stored the old one in the closet many years ago. Just remembered all the old family photos I had on it and so I removed both the master and slave drives from it in an effort to access the photos.

The master drive (also an EIDE drive) I was able to easily access with one of those USB cable solution things (you plug the EIDE drive in one end and plug the other end into a USB port; its Apicorn Drivewire but I dont think that makes a difference). the slave however WILL NOT SHOW UP IN WINDOWS 10.

I tried it in one of those enclosure kits next, also via USB. The master drive worked fine. The Slave will not.

I tried different jumper settings (master/slave) wouldn’t work. Its a WD caviar WD400.

When I go to Computer management I see it listed

Its Disk 5 , its dynamic and invalid. I know THATS the disk because when I pull the USB plug, it goes away and re-appears when I plug it back. Its listed as “working properly” but I cant access anything on it.

Any ideas?


It is possible the partition is corrupted. Have you tried using a data recovery software?

I did try some software that popped up in a google search… didn’t seem to do much… Any recommendations for software? one that I can try first and buy if I see it works? Id hate to spend $50 or more and turns out it doesn’t work