Need Help recovering data from unallocated drive

I have a usb 2.0 mybook essential 2tb that I have been having problems with for a year now. the transfer rates I was getting were extremely slow compared to when I first got the drive transfer rates were 24-30 megs per second at first then suddenly it dropped to 100kb-4megs per second. I ran the diagnostic test in smartware and it said I had bad sectors. So I decided to backup my data and try to fix the drive but transferring 1.4 tbs  of data at a rate of 2 megs per second would take forever.

I read that if I transferred the drive into another enclosure with with a faster bus the transfer speed would be faster so I took out the drive and put it in a esata enclosure but of course the drive did not. I tried putting it back into the mybook case but the drive started showing up as unallocated.

I want to know if there is anyway I can restore the file system and the file table without using standard data recovery software?

If I put the drive into a mybook usb 3.0 case will it be able to decrypt the data?

The board with the USB port controls the enccryption. Unless you use that board any data recovered will be encrypted and ueless. So cjanging enclosures or hooking up as an internal are a waste of time and money. Sorry there isn’t more I can offer. In the future make a backup. That means at least 2 different copies in different places.


Okay I got the drive connected to the original board again, if I run data recovery software can I retrieve all my files? Is it possible to recover file format and file table? I dont want to recover files one at a time, that could take forever.