Need help! My book 6tb

I can not get my 6tb to work, the case fail so I pulled the drive out i also have a 4tb same kinda case but older and tried that with nothing. I’ve tried my dock which it says it’s only 74.50gb disk management says tge same and other times it says nothing. Now a few times I’ve put It in my 4tb case it would show the right size but only through the WD utility but it won’t let me do anything. Then other times it says 0 bytes in the WD utility. Idc about what was on the drive since I’ve lost that already but I need this to work idc about the case I have an older my book or a duel dock I can use. I just need it to work.


If I buy another one which I’m about to do but can only afford the 4tb at the moment can I use the case to get the 6tb working again if the boards/chips used in both cases are the same?



WD My Books feature Hardware Encryption so you can’t just simply remove the hard drive from the enclosure and put it in another one to access your data.

The only option that will appear if you do so is to format the drive (which you’ve discovered)

In saying all of that … some users have been able to “decrypt” data on the WD My Books when they’ve been removed from the enclosure, but it requires the use of Linux. (links to guide in the topic below)

What is that have the same chipset or whatever in the case? The pictures I posted were from my 4tb my book case because the 6tb case failed it’s only a few months old too the HDD says March 2019 on the ■■■■ drive which i know the drive it’s self is fine just the board in the case crapped out. But the 4tb is same newer style just maybe a year older also yeah in my research over the last week of messing with this I had seen the “decrypt” but if I do that ill only be able to use it in Linux correct? I have a USB 8gb stick to boot into ubootu and even tried Gpart but I run Windows 100% of the time on both my labtop and tower. Also thank you for tge reply ive been going craxy AF about this driving me nuts. To be honest I think is WD is doing that to their drives I might make a switch over to a new company which I’m sure they have lost alot of people due to that reason. My Seagates the 3 I have 3tb, 2tb and 500gb never an issue and the 3tb is newer the 2 and 500 are atleast 5-7 years old newer any problems and all pulled from cases i use in my dock.