NAS to USB backup creates duplicate files

Testing methods on Mirror Gen 2, a shared folder backup to an attached external USB device. I created the job, see attached capture. I wanted to check job behavior after adding one new file to the share being backed up. The job finished quickly confirming only new files transferred and copied the new file, as i was looking for.
The problem is I noticed the backup directory device had ten more files than the original share, and the files duplicated are random and not sequential. None of these files had been altered. I ran it again and the exact same ten files were again duplicated, with each file name appended in order.

My goal is still to re-create the SafePoint behavior from the MyBook Live products pre-My Cloud, but this is completely anomalous behavior with no obvious reason to happen. It could be the MyCloud OS even. Anyone seen this or have any ideas?

Note: I used MyCloud web interface to originally transfer the files from another USB device plugged into the Mirror to the shared folder on the mirror.

I include this as I noted another odd behavior. The single file I added to the share when testing the job behavior, i moved it manually from the shared folder to the root of the external backup device to perform another test to see if the job would also remove deleted files in the share. Doing so actually removed that file immediately, before the job was run, from it’s corresponding location on the backup drive. Somehow the two seem to be logically linked, even though they existed on two separate physical drives, and the backup job was not running nor set to run when connected(also see attached).

Why/how could that happen??

Hello WillieAT,

During NAS to USB backup, it does not only backup files that have been changed or modified since the previous incremental backup. The entire content is saved to a different directory. So this would be the cause of duplicate files. You may refer below article for more detail about this.

Tx. It seems I must have gotten distracted and not kept up with responses. I still have the same problem. WD had a good thing with safepoints on the MBL product. There are so many reasons they should restore this ability. Synology at least provides an interface to use rsync rather than hacking the NAS OS, which I have not tried. WD is about to lose a very long time customer.

Drip Drop…

Which means what @brannonb?

I agree! Merry Xmas!

:wink: and every Cloud device has an Acronis app except the Mirror Gen 2… of course what i have. According to acronis it’s WD’s responsibility. I don’t want any option that requires constant operation and monitoring of an attached PC. I want the NAS itself to take the processing burden, just like safepoint did. :roll_eyes: oh well, I’m going to have to take the risk of shelling into the NAS OS and try configure rsync.

Edit: oh and Merry Xmas to you…LOL me my hero is the Grinch!