NAS - Source Has Been Removed

Hello everyone! Hoping to get some help here. Been having a heck of a time getting the media library piece of this working. I had added the Linksys Mediahub’s main folder (named Media) via the ‘add network share to media library’ button. It added it and compiled for about 2 hours. I made sure the wdtv.cas2 file was being written to up until the WD TV Live’s LEd stopped flashing. When it was done, i tried going into the Videos tab on the main menu and the load symbol came up for a bit and then I got the message: ‘The last content source has been removed. Please selecrt a new content source.’ My Media Library is no longer an option. Any ideas? After discovering this issue, I connected to the router using a wire just in case the wireless was causing a problem.              

I get that every time I power off the SMP.  What resolves it for me is clearing the stored credentials, then going to manage the Media Library shares folders (none of them are listed any longer, although they should be) and readding one of the folders.  You will be prompted for credentials, so reenter them.  Let it scan the new folder and within a minute or so all of your old folders will suddenly reappear.  Your issue may be different, but you might give it a try.

Awesome…thanks for the tip! They did disappear after I powered off, and I had added them all back in (10 in all).

If (or more likelty when) it happens again, I will try that.

A bit annoying if each time i power off it needs to be re-added.

It is very annoying and renders the device unusable by my wife and kids due to the number of steps involved in the workaround.  On the server side, an “unknown user name or bad password” event is logged.  The SMP is sending “anonymous” and a null password instead of the previously entered credentials, even though “save password” was selected.  Because of that, none of the folders can be accessed and Media Library is disabled.

Using the newest firmware update posted yesterday, I can put the box into standby (quick press of the power button) without losing credentials, but I still get the issue if I do a full power off (three-second press of the power button).  The previous firmware gave me the issue either way, so I had to leave the SMP on at all times.  As long as I left it on, the error conditioin did not occur, but that is a crappy workaround (as is reentering credentials all the time).

Toddler, you’re reporting a new symptom above (or, at least, I didn’t notice it in your prior posts in other threads), and I would like to know if this is actually a correct interpretation:    EVERY time you have the issue of it not remembering your password / login, has it ALSO always lost the members of the Media Library?

If so, that is a DIFFERENT issue than what I was assuming, in which case, I *do* randomly see THAT issue.   It’s not nearly as persistant is yours; it has happened to me maybe three times since version 1.05.   But not every time…   In fact, I often unplug mine and move mine around and still don’t have an issue logging on.

So, in reality, it’s giving you a login error because the system has lost the media library members, it’s not just that it’s lost the LOGIN.   Is that right?

Your interpretation is correct.  Every time I have the issue of it not remembering my password/login, and it has also lost my Media Library members.

If there is confusion in what I’ve been reporting, it may be that I’ve gotten better at reproducing and describing the issue since I first got the box and joined the forum here about a week ago.  But my experience has not changed.  Other than as I said, this used to occur on power cycle and standby, where now on the 1.06 firmware it only occurs on power cycle.

Ok, thanks for the clarification!

I’m having the same problem “source has been removed”, but have not noticed what triggers it.  It happened twice tonight.  Once was when I was watching an .avi and paused it.  When I resumed play, I received the error that the network had been disconnected.  I cannot remember what caused it the 2nd time.  Still using firmware v1.05.18

Seems to be working after doing what you suggested.

Yeah, we are about to cancel cable for some streaming devices, and we got this one for our bedroom, but if it keeps losing connection, I’ll have to go with something else for the kids and the living room.

I appreciate that you marked my post as resolving your issue, but I hope this isn’t considered to be “solved” per se.  Avoiding a full shutdown is simply a workaround.  As you stated, this behavior means you won’t purchase two more units for other rooms, and I quite understand that.  So I hope WD is still taking a look at this and doesn’t simply expect end users to deal with the issue.

Yeah…they should add a 2nd option for ‘workaround’.


+1 I have this problem aswell, turning it off via the remote is fine - it remembers my network shares etc. But if i turn it off via the wall socket i get the Network Source has been removed. But on mine i just choose Network share - Windows Share - then my NAS and i logs straight in - it still remembers my login credentials. Its not really an issue for me as i rarely turn it off via the wall anyways…

When you are using the remote, you aren’t really turning it off unless you hold power for three seconds.  If you just press power, it goes into standby.